Not earning rewards anymore since last 3 weeks

I am using Brave on 3 devices - an Android phone, a Windows laptop, and a macOS laptop. I had been earning BAT rewards just fine for the last 1+ year on all three, with verified connections to Uphold and now Gemini (on all but the phone).

Now, out of the blue, the windows laptop stopped earning BAT and disconnected from Gemini. I see the ads but earn no BAT. I have been stuck on 0.265 BAT since the beginning of this month. I am also greeted by the following message every time I try to connect Gemini (or Uphold, tried that too):
“Your request is still being processed, please wait.
Sorry there was a problem processing your request, please try again.”

I have tried restarting my computer, disabling and re-enabling rewards, software updates, etc. to no avail.

What should I do?

You should probably DM the moderators. Include the following information for each of your devices:

  • Copy/paste your Wallet ID (found on brave://rewards-internals )
  • Your OS and Brave version (first three lines in brave://version )
  • A screenshot of your Rewards panel in `Settings → Brave Rewards

Mattches and Steeven are the moderators who handle most of the rewards issues.

How to DM a moderator:

  1. Click on their icon and select the Message button in the top right corner or
  2. You can go to your profile and create a new message in Messages.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.