NOT ABLE TO VIEW PDFs ON BRAVE OR ANY CHROMIUM BROWSER!

I am not able to view any pdfs on brave or any chromium related browser !!

Just a blank document shows up when i try to open downloaded pdfs on brave or any chromium broswer !!

The pdf doc opens up on edge, but just shows up blank on brave and chrome !!

I’ve tried all the suggestions that came up on the internet when i tried to search up the solution. And there is no ptoblem related to the extensions since the pdf doesn’t open up on private tab or incognito mode either.

Need to solve this problem asap !



@cascadedstrom

Please provide:

  • Computing device Operating System
  • Brave Browser version numbers
  • Number of Extensions you have installed

Extensions tests:

  • Disable
  • Remove
  • One-at-a-time
  • Combinations

Microsoft Edge is a Chromium browser.

Please clarify why you chose the ‘Sync’ category and ‘sync’ label.

1 Like

OS - Windows 10

Brave browser version - [
Version 1.40.105 Chromium: 103.0.5060.53 (Official Build) (64-bit)

Number of extensions - 3 (that doesn’t matter since the pdfs are showing blank even in private window / incognito mode). I’ve tried disbaling all extensions and it still does not work.

There is no specific reason I chose the sync category. I didn’t know what category to choose, so randomly chose that.

I just tested on my PC and dragging PDF over opened with no issues. I’m going to throw out a very wild guess that may be completely wrong and silly, but sometimes it’s worth a shot.

If you go to brave://settings/content/pdfDocuments is it safe to say it’s currently set to Download PDF? If so, do you mind switching to Open PDF's in Brave and see if it fixes it?

Mine was already set to Open PDFs in Brave and I had no issues. Then I tried and it went to white screen but had a pop-up for me to save or whatever. So I’m assuming that’s the solution…but since we saw slightly different responses I didn’t want to say it with absolute certainty… lol

@cascadedstrom

Problem is likely to occur, because the presence of SPACE characters in the PDF file names - that exist BEFORE the downloading to your computer.

The string: %20 represents a SPACE character.

A test:

In a Brave Browser > New Window, go to: brave://settings/content/pdfDocuments?search=PDF and set to Open PDFs in Brave

Visit the site where you downloaded the files and try to view the files (given, that setting has been pre-arranged).

You will very likely be able to view the PDF files, via the PDFium extension that is built into Brave Browser.

Chromium itself, is a web browser. From a description at chromium.woolyss.com:

https://chromium.woolyss.com/?stb=1#windows-64-bit

Chromium is a blend of different important open-source projects:

You might try the Internet Download Manager (IDM) extension. Use it to directly download troublesome files, and then view the PDF files, by using Adobe Acrobat Reader or some other PDF application on your Windows 10 machine.

Brave Browser does not [yet] have a user-accessible file handler table, such as the Firefox handler table:

Screen Shot 2022-06-13 at 10.57.16 PM

Brave Browser for desktop computers, does have some ability to determine the course of action for some situations, if you send a New Window to: brave://settings/content

And scroll down that settings page, and toggle the arrows for expanding:

  • Additional permissions
  • Additional content settings

@CerealLover has some tips:

@cascadedstrom , @Saoiray (no problemo, and do not worry, tx)

Test file (found in a comment by @celem) . . . to download or view in Brave Browser (via the aforementioned, built-in PDFium). No SPACE characters. The file is large and takes a little while to download, for some users:

A very simple PDF file for testing, courtesy of W3C. No SPACE characters:

Last note: I would not only Disable, but also Remove all extensions - for testing.

2 Likes

Ha! I beat you to it for a change! LMAO. I’m hoping it is just that one simple bit, but at least you put a lot of other information there if it doesn’t. (^_^)

2 Likes

Mine has already been set to open pdfs in brave and it still does not work :sob::sob:. It used to work fine a few days ago, idk why it isnt now

It was already set to open pdfs in brave and still doesnt work. Everything used to be fine like a few back, idk why im having this problem now

@cascadedstrom , @Saoiray

I will leave the issue, and you all can figure it out.

You usually know a lot more. If you have guesses, go for it. Hope you’re not saying that simply because I tried joking with you a bit. (Earlier trying to say how you know a lot and answer a lot of things fast. It’s not complaint or anything)

Well, I’ll try to research a bit and see if we can’t come up with any solutions. If not, we’ll call in the cavalry, which will be getting someone from Brave to answer tomorrow.

1 Like

Thank you so much for the help

1 Like

I’m still racking my brain over here. I know you said you tried in Private Window and all. For it to be working for me, it doesn’t seem to be a Brave issue. I’m trying to think what else might play a part. Mind doing another simple test? Can you click on the hamburger menu and Create a new profile?

Assuming won’t fix, especially since it’s happening with you on Chrome, but been shocked at simple solutions working at times.

1 Like


Thanks for the suggestion, Saoiray. I tried it out and it still doesn’t work

I’ll just use edge for now. Thank you for the help. I guess there is something wrong which we can’t fix. You can leave it here.

Hi

Create a new profile, call it TEST.
Open pdf to check if working
Delete TEST profile

Result?

If working, something might be broken in . May be the Mimehandler to create pdf file; check it by right-clicking on Brave icon at bottom corner of taskabar and by choosing taskmanager. This icon only appears if you have set Brave to continue running in the background @ brave://settings/system

If Mimehandler is ok, try this:

  1. Disable shield for the pdf viewer page
  2. Clear browser cache for the last week
  3. recheck if Brave opens pdf @ brave://settings/content/pdfDocuments
  4. flush dns
  5. restart pc
2 Likes

Yeah, I’ll stop for now. Will hope @Mattches can swing by with the solution when he comes in. Wish we could have gotten the solution forn you here tonight

1 Like

Heyyy. It worked after I cleared the cache, flushed the dns and restarted my pc. Thank you so muchhh

2 Likes

it is working now after i cleared cache of the past 7days, flushed the dns and restrated my pc

2 Likes