Not able to download pdf documents on iPad

Hi

Thanks for a great browser.

However I have a problem downloading pdf documents on my iPad. This might also be a problem with other types of content.

Device: iPad Air 2, iPadOS 13.4.
Brave: 1.15
Other programs installed: Adobe Acrobat Reader.

Steps:

  1. Open below page and scroll to the bottom:
    https://gentofte.viewer.dkplan.niras.dk/plan/31#/lokalplanid/519
  2. Press ‘Hent pdf’ (load/get pdf) below the picture. Or longpress to open menu. (Here it’s not possible to download/save/open with.)
  3. Below page is opened.
    https://dokument.plandata.dk/20_9470281_1549281185059.pdf
  4. Here are the options I tried, in order to download the pdf.

4.1) Downloads
a) Press …
b) Press Downloads
Nothing in Downloads (waited a while). Only ‘Done’ shown.

4.2) Share with…
a) Press …
b) Press Share with…
c) Tried all I could think of…
I know I can go via e.g. ‘mail’ and save it, but that is quite a detour from the ‘obvious’ choices ‘Archives’ and ‘Adobe Acrobat Reader’. They are not there.

Anything I have missed, or is it a bug or missing implementation?