Not able to claim rewards

While claiming rewards, it says ‘Oops, something went wrong, please try after sometime’. This has been recurring for the last 10 days.

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


Description of the issue:

While claiming rewards, it says ‘Oops, something went wrong, please try after sometime’. This has been recurring for the last 10 days.

How can this issue be reproduced?

  1. The error message should guide for further action, if something needs to be done at the user’s end
  2. To be suitably fixed, if it’s a big

Expected result:

Should allow rewards
Brave Version( check About Brave):

Version 1.14.1 (19.12.05.18)

Mobile Device details
iPhone XS
Additional Information:
I could claim 1st reward only. Since then this is issue is coming

Same issue for me on iPad. It days my December rewards are ready to collect, tapping the claim button results in ‘oops’ message. This is the second month like this now. I have tried fully quitting and reopening the app, and checked that in on the latest update.

@dinesh @Stiviepoops,
Can you tell me when you enabled Rewards in the browser? Is this the first time you’re attempting to claim a grant/payout? Or have you done so successfully in the past?

My 1st attempt was successful. Ever since then, haven’t been able to claim - for the error msg as mentioned earlier.

@dinesh,
Did you un/reinstall the application at any time?

Not yet done, incidentally.

It’s resolved now. May b some patch was pending.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.