Non-breaking hyphens display as boxes

Description of the issue:
In several common fonts, text containing non-breaking hyphens (Unicode U+2011 or & # 8209 ; ) displays a box instead of a hyphen.

How can this issue be reproduced?

  1. Load any website containing a non-breaking hyphen in various fonts including Verdana, Arial, and Times. For example, the page shows those three fonts plus Palatino (which works correctly).

Expected result:
The word “non‑breaking” should display with a hyphen in the middle, not a ▯. The glyph exists in all of the fonts mentioned above, and other browsers display it correctly in all 4 fonts.

Brave Version( check About Brave):
1.35.104 Chromium: 98.0.4758.109 (Official Build) (x86_64)

Additional Information:
Other browsers tested on MacOS 12.2.1 (x86_64): Safari 15.3 (17612., Firefox 97.0.2, Google Chrome 99.0.4484.51 (does NOT work correctly, same as Brave).

Other browsers tested on iOS 15.3.1: Chrome (DOES work), Firefox, Safari

1 Like

@lincmad ,

Using a Mac, with Brave Browser v1.36.111; and a Private Window with scripts blocked, and 3rd party cross-site stuff blocked:

Screen Shot 2022-03-07 at 9.34.52 PM

I just now upgraded to 1.36.111 (the “check for updates” feature on v1.35.104 gave me a never-ending rotating cursor for some reason, but I manually downloaded the new one). However, I still get the problem, in a regular window or a private window. (I didn’t bother to disable scripts or cross-site stuff, because the test page has literally nothing but CSS styles to set the fonts and then the sample text).

The problem also still shows up on this page, directly under “Expected result” in the original post.

Screen Shot 2022-03-07 at 20.53.48

The issue is still present in Brave 1.36.112 (Chromium 99.0.4844.51).

The issue is definitely with the Chrome engine, not with my Mac, because the issue only appears with Brave and Chrome browsers.

I think that you are correct. As such it will likely require an upstream fix. I’ve informed the team of this issue in either case.

1 Like

I stumbled upon another issue that appears related. On the English Wikipedia page for Croatia, the pronunciation of the Croatian name Hrvatska in IPA symbols is mangled beyond recognition. The text in question is, in ASCII (minus the & and with spaces added for clarity),
[ x #x0159; #x0329; #x028B; a #x02D0; tska #x02D0; ]

Character U+0159 displays correctly, but the other three character entities do not. The Apple Dictionary app displays them correctly, AS DOES CHROME.


I am currently using Brave 1.36.119 (Chromium 99.0.4844.83) and Chrome 99.0.4844.83 on MacOS 12.3.0 (x86), which suggests that this problem is at least partly in Brave itself rather than in the Chrome engine.

@lincmad ,

I haven’t encountered any case of Brave incorrectly displaying basic ASCII characters, particularly not displaying them as Devanagari. That seems likely to be a different issue from this case of mangling some non-ASCII characters. Take a screen grab and post it as a new thread, along with details of the website(s) where you encountered the problem, version numbers of Brave and the OS, etc.

@lincmad ,

My (first) guess, is that both problems are in Chromium, and might be closely related.

Roughly around the time that you made the OP, was about the same time when foreign language characters appeared instead of English. First, Russian, then lately, Devanagari.

Occurring first, in search engine results . . . but lately, creeping into pieces of some webpages (examples of, I included in the link I provided).

As if, somebody is messing around in a certain area within Chromium?

I am concerned about a potential intruder, who is testing pathways into Chromium.

But, I just checked by way of Safari, and get the same result - foreign characters in some portions.

So, maybe a situation not related to your OP. Apologies.

Hello, @lincmad. I couldn’t reproduce these issues in Brave Nightly (1.39.10 / 100.0.4896.46), so I downloaded the official current release (1.37.109 / 100.0.4896.60 - guess Nightly needs updating). Neither issue appeared in the current release, either, so since the version is a bit farther on than the last you reported, perhaps updating will fix the issue?

There’s a slight chance that it’s a Monterrey thing. I’m on an old Intel MBP running macOS Version 10.14.6, but when I leave the office I can check on a Mac running macOS 12.3.


Turns out this machine is running 12.2, and while the non-breaking hyphen shows fine, the Croatia page has display issues:

I’m updating to 12.3 and will test again, but it looks like it could be a Brave+Monterey thing, after all.

Well, this is just weird. Brave in 12.3 also had the issue on the Croatia page, only maybe worse than 12.2, so I started tinkering with the brave://settings/fonts option under Appearance in Brave Settings. This showed the issue on the non-breaking space page @lincmad created, too.

@Mattches There really appears to be an issue with the way Chromium-based browsers handle 12.3’s versions or renderings of the on-board sans serif fonts. Brave and Epic (based on Chromium) both show the issue, while Firefox and Safari do not. Of course, I can’t figure out how to change fonts in Safari and it’s probably using Helvetica, which works fine in Brave, too.

This is hardly exhaustive, but in Brave, Verdana, Trebuchet MS, Skia, and PT Sans yield boxes or spaces where the special divider characters are, but Arial, DejaVu Sans, and Helvetica work fine. The ages of most of these are suspect because I’m using the listed copyright dates, and Helvetica demonstrates that the copyright date may not reflect the date the version was actually created.
     Verdana (Version 5.01x (c) 2006): image
     Trebuchet MS (Version 5.00x (c) 2006): image
     Skia (Version 13.0d1e54 (c) maybe 2014): image
     PT Sans (Version 13.0d3e2
(c) 2009): image
     Arial (Version 5.01.2x (c) 2006): image
     DejaVu Sans (Version 2.37 (c) 2006): image
     Helvetica (version 17.0d1e1; 2020-09-21 (c) 2006): image

@hnktong ,

Via another discussion, re TOR disconnected, a link provided by @Mattches

Shows strange foreign characters:

Screen Shot 2022-03-30 at 11.11.09 PM

Brave Browser Version 1.37.109 Chromium: 100.0.4896.60 (Official Build) (x86_64)

1 Like

While I cannot reproduce this issue, I believe that the underlying cause is this Chromium bug:

This was supposed to be fixed in cr98 but apparently it was not. At any rate we’ll likely have to wait for an upstream fix for this. Apologies for the inconvenience. I’ve reached out to our macOS team with this info as well, just in case they know more than I do (they usually do).

1 Like

I have updated to macOS 12.3.1, Brave 1.37.111 (Chromium 100.0.4896.79), and Chrome 100.0.4896.75, and I found the following results:

• both Brave and Chrome continue to incorrectly display non-breaking hyphens
• Brave continues to incorrectly display the IPA symbols in the Wikipedia “Croatia” page, but Chrome displays them correctly
• Safari and Firefox continue to display all of the above correctly

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.