No way of removing 'Tip' button from Twitter

There’s no way of removing the ‘Tip’ button on tweets on twitter - there is a setting in hidden in a sub menu at the bottom of brave://rewards/, but that does not work. Turning off ‘Content-Level Tips’ for Twitter does not affect that the Tip button is jarringly there on every tweet

I really appreciate Brave - it’s a good browser - but sneaking in a vanity button onto every post on a third party site, a ‘feature’ that is turned on by default, with an off-button that’s buried in a weird unsearchable corner of the settings which doesn’t even work is a pretty big stink.

This was raised before here but was closed before any action was taken:

If you try Brave settings, brave://settings/appearance

Click on Hide Brave Rewards button then refresh Twitter, does that help?

I’ve given this a go and this doesn’t seem to fix it - it just removes the Brave Rewards button from the address bar, but doesn’t get rid of the embedded ‘Tip’ button on tweets

having the same issue. bumping so they don’t close this thread.
what a ridiculous addition.

Reported the issue as a bug here https://github.com/brave/brave-browser/issues/13223 which also may be related to this bug https://github.com/brave/brave-browser/issues/13222 this was reported over on this Reddit thread https://www.reddit.com/r/brave_browser/comments/kegyqc/is_there_a_way_to_permanently_turn_off_tips_i/

I too was puzzled when I seen the triangle showing up one day on Reddit and Twitter especially when I have Brave Rewards/BAT turned completely off from day 1 in the browser. Why this would be enabled in such a case is puzzling. This option should only be ENABLED if the browser has Brave Rewards/BAT enabled.

Update: I’ve looked around the github repo to see what’s going on, and it looks like this is a known issue - the disable tip button does work, it just requires a restart of Brave to take action. It’s not great that this is required without any indication, but the devs are aware of it and working on it. (Make sure you close all windows, as the first time I did this I accidentally left a window open in an alternate desktop and it didn’t work - verify in taskmanager there’s no brave.exes left).

The main discussion of the issue is here: https://github.com/brave/brave-browser/issues/12870

They’re aware people aren’t happy but they’re working on it - sounds like the settings will work without restarting next release

1 Like

@zbzbzb,
This is correct – we appreciate your patience and understanding.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.