No usable sandbox! Error with CentOS 7, kernel 3.10

linux

#1

Hello guys, you’ve done a good job with the Brave browser and it runs well with almost every linux distributions that I’ve tried, but, here is this issue with CentOS 7, when starting brave, I get the following error:

[6:6:1003/112949.103980:FATAL:zygote_host_impl_linux.cc(107)] No usable sandbox! Update your kernel or see https://chromium.googlesource.com/chromium/src/+/master/docs/linux_suid_sandbox_development.md for more information on developing with the SUID sandbox. If you want to live dangerously and need an immediate workaround, you can try using --no-sandbox.

I’ve tried the suggested workaround in the given link and it didn’t work. Brave runs well with --no-sandbox option, but it’s not safe to run it like that. Another fix that I’ve found, is to use the latest lt kernel from a third-party repository but again, this kernel has no support from the core team of CentOS and thus, it is not an option as well. Thant’s why I’m asking for your help.

Thank you in advance!


#3

Duplicate of Fix -no-sandbox error on RPM based distros