No sound after removing second screen; Ubuntu

bug
#1

$ uname -a
Linux Morpheus 4.18.0-16-generic #17~18.04.1-Ubuntu SMP Tue Feb 12 13:35:51 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Brave:
Version 0.59.35 Chromium: 72.0.3626.81 (Official Build) (64-bit)

Bug:
No sound after disconnecting the laptop from an extended screen. This is isolated to Brave since other applications and browser are not affected

frequency:
every time a disconnection from an extended screen is done.

0 Likes

#2

@kalonji,
I see that you’re using an outdated version of Brave. The most up to date version is v0.61.52 – can you update to latest and let me know if this is issue still occurs?

0 Likes

#3

this is the latest brave version on the snapcraft repository.

$ snap refresh brave
snap “brave” has no updates available

$ snap refresh brave --stable
snap “brave” has no updates available

Is the snap repository not up to date with the latest stable released version?

0 Likes

#4

@kalonji,
That is correct. As it says on our Linux install instructions on the Help Center:

Brave installation via Snap is no-longer officially supported . Since Snap is community-driven and Brave cannot guarantee that they are up to date with our security updates.

Run the installation instructions found in the page linked above and you should be updated to the latest release. Please let me know if this does not resolve the issue with your second screen/extended display.

0 Likes

#5

Problem still persist, after removal of the old package and install of the latest release of brave; Version 0.61.52 Chromium: 73.0.3683.86 (Official Build) (64-bit)

0 Likes

#6

@kalonji,
Sorry for the late response. Looking into this – I’m wondering how you have your display set up? Are you using any associated software to manage multiple displays, just HDMI --> machine, etc?

0 Likes

#7

simple HDMI --> Machine, btw i had to recently remove brave due to another thread Syslog overflow, Don’t know if its related/caused/symptom of this problem

0 Likes

#8

@kalonji,
Last clarifying question – when disconnecting the second screen, do you have sound playing at the same time? Or is it stopped (or doesn’t matter) and then after you disconnect trying to play [sound] in the browser fails?

0 Likes

#9

No media was stopped then cable was removed, but the problem is resolved newer version, installed through apt-get repository, seems to clear the problem. plus the other threat seems to be resolved now. it was due to improper uninstall of the snap brave application.

0 Likes

#10

I retract that last comment, even tho the other thread is solved, this one still remains

0 Likes

#11

This time for real problem solved, purged nvidia drivers and reinstalling them using the ppa repository for nvidia drivers. Thanks for all the help, I should of know that the solution was easier than expected

2 Likes

#12

@kalonji,
I’m glad you got this resolved! Great detective work. Appreciate your patience and don’t hesitate to open a new topic should you have any further questions or concerns.

0 Likes

closed #13
0 Likes