No shield settings on file:// pages


#1

Hello, thank you for your time. Shield settings are unavailable on file:// type pages, as well as about: pages. I’m creating a website and testing various scripts from my computer, it would be nice if I could edit the script settings from the page instead of enabling or disabling globally. When I try to, the Brave logo in the top-right is greyed-out instead of orange-ish, and doesn’t respond when clicked. This feature is available in Firefox using NoScript, it looks something like Allow scripts permanently from file:///?

uname -a:
Linux Debian 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1+deb8u2 (2017-03-07) x86_64 GNU/Linux

about:brave :
Name Version
Brave 0.14.1
rev 3de60d5
Muon 2.57.8
libchromiumcontent 57.0.2987.133
V8 5.7.492.71
Node.js 7.4.0
Update Channel dev
os.platform linux
os.release 3.16.0-4-amd64
os.arch x64

Step by step recreation:
i. Opened file:///path/to/source.html through omnibar
ii. Attempted to run a script, which was blocked by Brave’s global shield settings
iii. Attempted to enable JavaScript for this file only (or file:// types only)
iv. The Brave logo in the top-right was greyed-out and did not react when clicked.

I’m happy to provide more info if necessary.

edit: changed ‘default settings’ to ‘global settings’, since I changed them when I first installed the browse


#2

If you use a web server on localhost, you’ll be able to execute scripts as needed. Here are a few examples : https://wiki.debian.org/WebServers


#3

This topic was automatically closed after 18 days. New replies are no longer allowed.