No_pubkey a8580bdc82d3dc6c

Googling on this reveals a number of similar solutions, none of which have worked for me. e.g. https:||community.brave.com|t|missing-public-key-for-linux-updates/182721

# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 9.13 (stretch)
Release: 9.13
Codename: stretch

Following https:||brave.com|linux| apt-get update returns:

W: GPG error: https:||brave-browser-apt-release.s3.brave.com stable InRelease: The following signatures couldn’t be verified because the pub
lic key is not available: NO_PUBKEY A8580BDC82D3DC6C
W: The repository ‘https:||brave-browser-apt-release.s3.brave.com stable InRelease’ is not signed.
N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

# apt-key adv --keyserver keyserver.ubuntu.com --recv-keys
gpg: key 0BB75829C2D4E821: “Brave Software <support@brave.com>” not changed
gpg: Total number processed: 1
gpg: unchanged: 1
seems fine, returns

[Substitude / for each |, above.]

Suggestions?

I saw a response to this that essentially said known issue, expect to be resolved tomorrow. (Thank you for the note / confirming it’s not me.)

However … that response seems to have disappeared now / in this ‘Brave Community’ post. How do I make that response visible to me again?

Found that response:

Seems unrelated to this issue. Could someone please confirm the OP issues is still present IRL, or not?

Solved: “sudo chmod 644 /usr/share/keyrings/brave-browser-archive-keyring.gpg” from 0640.

Google fu finally worked - last post: https://github.com/brave/brave-browser/issues/7843, https://github.com/brave/brave-browser/issues/7843

Could someone add this instruction to https://brave.com/linux/ jplease.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.