No file picker dialog opening on linux when attempting to upload file

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting

Description of the issue:

Hello, I have been wanting to use Brave as my primary browser on Linux, however I am running into an issue. I cannot upload any files as the file picker dialog will not pop up when clicking an Upload button on any website I’ve tried.

Possible solutions I have tried: I have installed every variation of xdg-desktop-portal (wlr, kde, gnome, gtk, default) I tried installing kdialog I have set my preferred Ozone Platform to Wayland and enabled WebRTC Pipewire support in brave://flags Running brave from terminal with --verbose produces nothing at the moment of clicking the Upload button. Uninstalling and Reinstalling brave did nothing

I can get output from running dbus-monitor in a terminal and clicking an Upload button, which you can see at the link:

I’m assuming my issue can be identified somewhere in that output, but I do not know how to read it. Any help?

This is the rpm version of brave on SwayWM

How can this issue be reproduced?

  1. Run Fedora 37 with SwayWM
  2. Attempt to upload a file to a website (attachment on an email for example)
  3. The button is clicked but does do anything, no file picker pops up and nothing happens no matter how many times you click.

Expected result:

file picker opens to select file to upload

Brave Version( check About Brave):

Brave 110.0

Additional Information:

I do not know the answer to your problem.

Can you try brave beta or brave nightly and see if the file picker works. Then try to find the difference between the two browser and why it worked.

Or try the brave stable flatpack version and see if it works.

Now you are spamming in other threads which is quite bad. Do not do it, try to maintain your words in your own main thread.

You are likely gonna get banned at this rate.

1 Like

Hello @29487363748

could you disable all extensions and try in private mode?
could you reset all custom flags you set?
could you try to create new profile and see if it work fine there?

did any of those help to solve it

Hello, just tried all three of those things and experienced the same issue as before.

My concern with the Brave flatpak is that to my understanding the flathub repo is not maintained by the developers. If I am mistaken, I will give that a try.
I just tried installing the beta and nightly versions, both of which experienced the exact same issue.

Hello @29487363748

i never used SwayWM does it come with extra repo than the default that come with fedora?

could you try to install brave using the official repo

since you tried the default desktop environment

could you create new linux user account and see if it work fine there?

does any of those help?

is chrome has same issue ?

hope something help and have a nice day :slight_smile:

I am using fedora, I installed with dnf. SwayWM has no special repos for packages, and I tried Ungoogled Chromium and got the same results. Firefox opens a file picker

so i assume you use the dnf using the official brave repo

did you tried this

or not?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.