No camera detected with "ALLOW" on . See pics

Trying to use Facebook messenger camera/photo/video on Brave and it says NO CAMERA DETECTED even though i set Camera to ALLOW in the lock on URL bar and quit/restarted Brave. Black rectangles on pics just to block out FB user names. Macbook Air 2020, OS 10.15.5, Brave Version 1.9.76 Chromium: 81.0.4044.138 (Official Build) (64-bit)

1 Like

@amyvegan,
Thanks for reaching out. I have a couple ideas here:

  1. Can you try opening the Shields panel and changing the Fingerprinting setting to All fingerprinting attempts allowed? Allow the page to refresh, then see if your camera can now be detected.
  2. If the above doesn’t work, try enabling Autoplay for the site – I don’t think this is the issue but I’d rather rule it out now than try a bunch of other solutions only to realize it was this easy :stuck_out_tongue: Simply click on the lock icon in the address bar, then Site Settings --> Autoplay --> Allow
1 Like

thank you.
what is fingerprinting?
amy

1 Like

@amyvegan,
Fingerprinting (sometimes called Device Recognition) is a technique used to collect information and identify users (generally linking them to specific machines/devices). This is often a necessary technique in web development as it can be used to read screen dimensions/size/specs so that it, for example, will display the media content on the site you’re viewing correctly.

Did one of the two methods above resolve your issue?

1 Like

thank you. fingerprint “allow all” did not work.
have you tried facebook messenger (via brave on laptop/desktop) to see if you can take a video or photo?
i’m afraid to try AUTOPLAY because then won’t videos run on their own? i hate that.
amy

1 Like

@amyvegan,
Enabling Autoplay very well may do that – and if that’s the case then I’ll have to file an issue for the devs to review (because autoplay should need to be allowed for this feature). However, it’s a very easy test to try, since if it doesn’t work you can simply set it to Block again. I do know that we’ve had, in the past, issues where sites like google hangouts/meet would not function properly until autoplay was enabled, which is why I’m curious if this may be the case here.

If that doesn’t work, I’ll reach out to some of our Shields experts and get some additional eyes on it. Appreciate your patience.

1 Like

I’m having this issue too. And Brave used to work just fine, and I don’t think I installed any Brave updates between this time period.

I tried both suggestions and neither finger printing worked (there were 0 blocks fwiw) nor autoplay enabling, autoplay was already enabled (default) fwiw. I did toggle it from blocked back to enabled.

Brave 1.8.96 Chromium: 81.0.4044.138 (Official Build) unknown (64-bit)
Revision 8c6c7ba89cc9453625af54f11fd83179e23450fa-refs/branch-heads/4044@{#999}
OS Linux
JavaScript V8 8.1.307.32
Flash (Disabled)
User Agent Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36
Command Line /usr/lib/brave-bin/brave --enable-dom-distiller --disable-domain-reliability --no-pings --extension-content-verification=enforce_strict --extensions-install-verification=enforce --sync-url=https://no-thanks.invalid --enable-features=PasswordImport,AutoupgradeMixedContent,PassiveMixedContentWarning,MixedContentSiteSetting,SimplifyHttpsIndicator,WebUIDarkMode,DnsOverHttps --disable-features=AutofillServerCommunication,NotificationTriggers,TextFragmentAnchor,AllowPopupsDuringPageUnload,SmsReceiver,AudioServiceOutOfProcess,LookalikeUrlNavigationSuggestionsUI,VideoPlaybackQuality --flag-switches-begin --allow-insecure-localhost --load-media-router-component-extension=1 --flag-switches-end --disable-webrtc-apm-in-audio-service --disable-sync
Executable Path /usr/lib/brave-bin/brave
Profile Path /home/elijah/.config/BraveSoftware/Brave-Browser/Profile 1
1 Like

Similar issue here. I am using Brave to access my Google Calendar and in particular Google Meet, but when using Brave it does not acknowledge that I have a USB webcam. It only detects the integrated camera on my laptop. Chrome uses the USB camera just fine.

1 Like