New version of Brave breaks ITVx streaming site

@The_RiViT I’m going to ask you to check a few things. Try one step at a time. If it “fixes” it, then stop there and let us know which one. Otherwise move on to the next step.

  1. If you go to brave://settings/extensions, do you have Widevine enabled? If not, enable it

  2. Can you try in a Private Window?

  3. Go to your hamburger menu and Create a new profile.

  4. This one is more annoying, but can you go clear cookies/cache? You can do that by going to brave://settings/clearBrowserDataAdvanced → change to All Time → Select Cookies and other site dataClear Data. NOTE: Keep in mind this will sign you out of everything.

Beyond that, also want to ask. Are you using anything like a VPN or proxy?

Registered to say I have the same problem.

Problem occurs on 1.47.186 legacy (Windows 8.1) and current 1.49.132 (Windows 10) Other browsers are fine.

I tried all the above. No VPN or anything.

Hi, all of the above tested.
Still exactly the same result.

Yes, I use a VPN, but this has no effect on either Chrome or Edge when streaming from UK terrestrial tv (all channels stream correctly)

Also, as a side note:
Brave is able to play (without issues while using a VPN): (which does require Widevine enabled)

This issue appeared to start when the latest and greatest version of the browser was auto installed.

Does adding into brave://adblock help?

I’m using an older version of Brave 1.47.186 and streaming is also broken for me.
I’m able to log in and browse the ITV site.
Everything was fine a few days ago.
The adblock string doesn’t help.

Agreed, the adblock doesn’t work for me either.

@The_RiViT @terrestrial Just out of curiosity, if you open the dev tools panel, do any errors show up under Console? Not sure if it’s the same or something different on Mac since I never used, but it’s F12 to open dev tools.

Kind of a stab in the dark here, but part of me wondering if any clues might be found.

Interestingly, I did see this using F12. (PC)

[InitialiseModel] setCore error TypeError: Cannot read properties of undefined (reading ‘min’)
** at Object.getFeatureSet (main.html5-desktop.min.js:125:11288)**
** at t.execute (main.html5-desktop.min.js:127:2227)**
** at l.r (main.html5-desktop.min.js:118:16262)**
** at t.execute (main.html5-desktop.min.js:118:5561)**
** at i.dispatch (main.html5-desktop.min.js:118:7665)**
** at i.dispatch (main.html5-desktop.min.js:118:5386)**
** at c.dispatch (main.html5-desktop.min.js:118:18229)**
** at w (main.html5-desktop.min.js:127:28124)**
** at main.html5-desktop.min.js:127:28263**
** at r (main.html5-desktop.min.js:127:19910)**

The above doesn’t appear in an active Chrome session

The rest is issues with /* etc, */

Hope this helps somewhat.

I am having the exact same problem. Has anyone worked this out yet or do you think Brave will fix this?

Thanks for this, works fine now. I urge everyone to try this.

So my suggestion works? just to confirm?

Yep :slight_smile: Just had to paste your code into the Create custom filters section and save changes. Video loads fine with no loading screen.

You said you put in the filter like Fanboynz mentioned, right? And is when you were saying it wasn’t working? Want to make sure you did the custom filter since frankm181 is saying did it and it works.

Thanks a lot. This fixed it pasting into Create custom filters

I can confirm the adblock filter has now fixed the problem for me. For some reason it took a few tries for it to work.
Good help, thanks.

Credit to fanboynz :grin:

OK, so…

Turning Shields on… (so the adblock code is running) and adding the custom string…
Lo and behold…

Next question to the brave Devs…

Out of interest… Why with no shields the site fails, but with shields and the custom string it works?
… Don’t have shields in operation on any of the other UK terrestrial channels.

Coding re-vist needed perhaps?

Fix will roll out to everyone in the next 24hrs. Ensure Sheilds, ads&Trackers is enabled on itv.

I must be doing something wrong as I the solution does not work for me. Mac mini with Ventura 13.3.1.

Thanks for the report @housebound

Rolling out a fix asap, as a temp solution add this into brave://adblock (custom rules)


Because of my severe disability I accidentally deleted the 'Create custom filters field. Is it possible to restore the former field ?