New version causing problems with Kongregate games

bug

#1

Description of the issue: All Flash games now have this message: “To play this game on Kongregate, you must have a current version of Adobe’s Flash Player enabled. Click here to activate or install Adobe Flash:” Clicking the button does nothing. I went to the Adobe web site and downloaded and installed Flash. Refreshing did not fix the problem. Non-Flash games either won’t run at all or say there is no internet connection. I’m on other web site so I know there is an internet connection.

Steps to Reproduce (add as many as necessary): 1. 2. 3. 1. Go to https://www.kongregate.com/ 2. click on any game that is listed. Crafting Idle Clicker and Pocket Politics are two that say they need an internet connection to run. 3. If it’s a Flash game try to click on the enable/install button. 4. If it’s a non-Flash game try to get an internet connection.

Actual Result (gifs and screenshots are welcome!): Gets stuck on either the window asking to enable/install Flash or an error screen saying there is no internet connection.

Expected result: The web site runs without errors. The install/enable Flash button works as intended.

Reproduces how often: Every time I try to use the web site.

Brave Version(about:brave): Version 0.57.18 Chromium: 71.0.3578.80 (Official Build) (64-bit)

Reproducible on current live release (yes/no): yes

Additional Information: I’ve been in contact with the developer of Crafting Idle Clicker for a different issue and was told Brave isn’t one of their supported browsers so there was nothing they could do.


#2

Hi @TPlon,

Can you click tge padlock icon at URL bar, then there you should see the settings for Flash. Change it to allow.

Let me know if it’s doesn’t work.
Thanks
:slightly_smiling_face:


#3

The padlock worked for the Flash games but the non-Flash games still show the error for no internet.


#4

Thanks for the update. For this one, can you share a screenshot of your Shields setting for that site? Click Brave icon at URL bar. Let’s see if something is blocked by Brave.

Usually, check if Device recognition blocked something. Then you can change it to “Allow all devices recognition”.

:slightly_smiling_face:


#5

@TPlon,
iirc, all games on Kongregate are Flash-games.
Did you have a separate site you were referring to with “non-flash” games that don’t work?


#6

I have turned off the Brave shields for Crafting Idle Clicker. I’m not sure if this will work, but I copied and pasted from PhotoFiltre 7 to here:

If it doesn’t work let me know what I did wrong.


#7

They might be but at least two of them did not give me the same error that the other games gave me.


#8

If you can take a screen shot of the error that would be great!

Edit: Did not see your above image. Looking into this now.


#9

I’ve run into a similar issue. For me, with shields up, the site keeps refreshing constantly, regardless of if I’ve allowed Flash or not. With shields down, however, it works okay.
I’m on Version 0.57.18 Chromium: 71.0.3578.80 (Official Build) (64-bit)


#10

Try opening your Shields panel and setting Device Recognition option to Allow.
The site/game may need to detect the type of device and size of the screen you’re using.


#11

I tried it and it didn’t help. I tried allowing everything and it still won’t run. It just keeps showing the same error.

For some reason it can’t detect an internet connection.

Here is the error message from Pocket Politics, the other game that won’t run.

Clicking “OK” just results in receiving the same error.

For now I am using Firefox to use Kongregate, but obviously I would like to be able to use one web site for everything.


#12

Does it work if Shields are off entirely?


#13

Actually, I just tried to run that exact game and have it up with no errors. This is with Shields up as well:

.
You’re using the release build (v0.57.18)?


#14

I allowed all device recognition. Still keeps constantly refreshing just as it’s about to load the Flash player. I’m on Windows 7 if it’s worth anything.


#15

Yep, I’m using v0.57.18 Still blocked.


#16

@poisonapple @TPlon,
This may seem silly, but can you try to play the same games in Brave but in a Private Window? You can open a private window from the main menu:
image
You can also launch a private window using the ctrl + shift + N (cmd + shift + n on macOS) keyboard shortcut.


#17

I got it to run while I was not signed into my account but as soon as I signed in, it showed the same error message.


#18

Just checked. The game works when launched in a private window. There’s no more constant refreshing. Do you know what’s causing this?


#19

This topic was automatically closed after 30 days. New replies are no longer allowed.