New tabs infinite loading + inaccessible developer tools

**Description: **
New tabs will sometimes get stuck in what looks like “infinite loading”. I say looks like because when this happens the developer tools and the brave://* pages become inaccessible, and therefore cannot confirm that it is actually trying to load anything.

When this happens the tabs with pages that were already loaded continue working (although it might throw an alert that the page is unresponsive).
e.g. If I have Twitch loaded when this issue happens I can continue using Twitch, even change the streamer I am watching, but I cannot load a new tab of Twitch (nor any other site).


This happens after a seemingly random period of usage. As It sometimes happens within a day and sometimes over a week goes by without happening.

It has been happening for months now, but I did not take note of what version it started in.


Just in case I will mention that: the issue does go away temporarily if I “turn it off and on again” but I do not think having to restart the browser can be considered a solution. Plus, having to reload everything I was using/working on is not exactly ideal…

How can this issue be reproduced?
TBH, no clue how to reproduce it… but it does seem like similar issues have been happening to multiple users for over a year now.

Expected result:
New tabs not getting stuck in an “infinite loading” and having access to the developer tools

Brave Version( check About Brave):
Version 1.45.118 Chromium: 107.0.5304.91 (Official Build) (64-bit)

Additional Information:
None at the moment. The issue happened again today, which is why I chose to post this.