New tab opening too slow


#1

When I use my browser and want to visit another website i open a new tab by Ctrl+T and then start typing the webadress right away. When I use Chrome or some other browser this i no problem but in Brave this isn’t working for me.
When i do this the first letter I write isn’t recorded in the URL.

I use Windows 10 and have google.com as my search engine.


#2

Hi @Balle

We have a couple of issues open around new tabs/slowness/performance. Based on your description, I think this one most closely matches what you’re seeing. Could you take a look and let me know if this sounds like your issue?

https://github.com/brave/browser-laptop/issues/9877

Thanks,
Lauren


#3

Well, its not really the same.
My problem is when I open a new tab - not a new window.
And I do have an url bar.
It just seem to react a bit slow and therefore doesn’t record my first keystroke.
For a fast browser like Brave it seems odd I have to wait a second when opening a new tab.


#4

Hi @Balle

If you go to Preferences > General, what is the setting for ‘A new tab shows’? If it is not ‘Blank page’ does changing this to blank page and trying again make things any better?

Lauren


#5

This makes it alot better. I just don’t wanna miss the dashboard. It doesn’t seem to be problem in other browsers. Even edge with the expansive “Feed” on the new tab react fast when opening.


#6

Hi @Balle

Thanks for doing that check for me! I’m fairly certain the issue is that the download of the images (which come from the internet and are not pre-installed when you downloaded the browser). We do have an issue logged for optimization in this area which sounds like it would resolve your problem. I’ve linked this post to the issue below:

https://github.com/brave/browser-laptop/issues/6503

Thanks,
Lauren


#7

Hi @Balle

I completely forgot about Preferences > Tabs, there is a toggle to turn off displaying images on the Dashboard. You could try that to see if this helps out with your issue and still allows you to see the stats on dashboard.

Thanks,
Lauren


#8

Well i did that, seeing the pictures were loading a bit slow - no change


#9

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.