New tab now loads fast but I want to get ahead of possible future regressions

I want to clarify that this problem has been fixed in the latest version, but want to point it out because it typically rears its head back in repeatedly. This problem has persisted for the past 2 years, and only stayed “solved” for 2 weeks before it regresses for another 6 months.

Description of the issue: Usually, these behaviors are in tandem. Either they’re all fixed, or they’re all in an undesirable state. There is no in between.
Real is the state that I perceive to be in regression. Expected is the desirable state that I observe on some versions of Brave.

1. New Tab
Real: Opening a new tab has a 5 seconds wait before the backgrounds appear. The wait exists if there’s no other new tab in the browser
Expected: Background loads almost instantly (<1s)

2. New Incognito Window
Real: Opening an incognito has a 5 seconds wait before the homepage loads.
Expected: Homepage loads almost instantly (<1s)

3. Opening latest closed tab (Ctrl+Shift+T)
Real: Opening latest closed tab has a 5 seconds wait
Expected: tab loads almost instantly (<1s)

4. Hard to pinpoint halt before loading a page
Real: Sometimes if I try to load too many pages, some of them halt for ~5s before resolving and starting to load. This also happens if I shift between incognito and non-incognito and load different pages.
Expected: Pages resolve and start loading almost instantly (<1s)

5. Hard to pinpoint problem where opening Incognito would break localstorage
Real: Sometimes after being in incognito and then closing incognito, my non-incognito pages would fail to persist localstorage changes.
Expected: Localstorage changes persist across tabs (<1s)

Video Link: https://drive.google.com/file/d/1vX-czxo2OYlIrwQMEGRqOUNY_x5Olc6q/view?usp=sharing
You can see a long wait when loading new incognito window, new tab, and reopening old tab. In a good state, it’s instant.

Brave Version: v1.42.88 (Good state)
Brave Version: v1.42.95 (Bad state)

I can go more into details about the behavior if needed. I wasn’t able to find issues relating to this on the forums, which confuses me, because the responsiveness degradation is very obvious.
All I can say is that on certain versions of Brave, it’s fixed. Later, the undesirable behavior comes back. (Typically after 2-4 weeks) It’s been in an undesirable behavior for most of 2 years for me, and I really want to know what’s going on because I suspect it’s a regression against Chromium that repeatedly gets missed. I’m really hoping that since the browser keeps switching between the behaviors, that it’s an easy fix.
I’m posting this so that hopefully a developer can see the difference between the versions and prevent future regressions.

1 Like

I tried running an older version to see if I can experience the undesirable behavior again, but I’m not sure if I’m doing it correctly.
I went to this link:

Downloaded the file: brave-v1.41.99-win32-x64
Ran the executable. No degraded behavior there.

Did I not downgrade properly? Or does this suggest the problem exists within Chromium and not Brave?

1 Like

And now the problem has come back. Yay
I’m glad that I can record the problem, but not glad that it’s back.
Brave Version: v1.42.95 (Bad state)

Video Link: https://drive.google.com/file/d/1vX-czxo2OYlIrwQMEGRqOUNY_x5Olc6q/view?usp=sharing
You can see a long wait when loading new incognito window, new tab, and reopening old tab.
In a good state, it’s instant

1 Like

@BlueDo,
Thank you for reaching out and for the detailed report.
If you create a new browser profile, do you see this same behavior there, or does the browser behave as expected/desired? When testing this, please ensure you only have the one (newly created) window open.

1 Like

Hi Mattches,
Thanks for the response. I went ahead and created a new Profile, but the problem still exists.

Brave Version: v1.42.97 (Bad state)
Video Link: https://drive.google.com/file/d/14z4K_UsWZC4d1FA8Wv4dk1Yqk__stE0K/view?usp=sharing

I also went ahead and downloaded an old version, and the desirable behavior is now back on both a fresh and old profile
Downloaded brave-v1.41.99-win32-x64.zip from github (brave/brave-browser/releases/tag/v1.41.99)
Brave Version: v1.41.99 (Good state)
Video Link: https://drive.google.com/file/d/1njd_hold3cU9VHGf2EXV1TD17XyO4tfU/view?usp=sharing

Edit: I also went ahead and ran the test with the version I had when creating the thread. The behavior is desirable on both profiles
Downloaded brave-v1.42.88-win32-x64.zip from github (brave/brave-browser/releases/tag/v1.42.88)
Brave Version: v1.42.88 (Good state)
No video since it’s the same as v1.41.99 but I can make one if you ask

Edit2:
Immediately after posting the videos. I ran the test, and all 3 versions are in bad state. I’m finding myself unable to replicate the good state again, even while following the steps in the videos. What is going on?

Edit3:
I have now tried opening browser with/without OBS running. The only time I got the desirable behavior again was when I was uninstalling Foxit Reader and it opened a survey on a browser. The bad/good behavior seems to be decided on startup and persist until browser closes. Also, when trying to open incognito, “Radeon Software: Host Application” seems to get very busy until the incognito homepage loads again.

1 Like

@BlueDo,
Thank you again for the detailed update. This is very strange behavior. Looking into this now. In the meantime, can you test and see if disabling Hardware Acceleration changes anything?

Settings --> Additional —> System --> Hardware Acceleration

1 Like

Hi Mattches,
I looked, and Hardware Accelerator was already off

I re-installed Brave and that didn’t change things.
One thing I want to mention is that I initially installed Brave beginning of 2021 through Chocolatey, but ended up re-installing via an installer afterward.
I do have a question: I have Brave and Edge installed on my computer. Do they “share” an install of Chromium? I’ve noticed in the past that when Brave updated with a Chromium bug, that Edge also had that same bug even though I hadn’t touched it in a while.
I’m trying to find ways to uninstall Edge with no success so far (another anomaly), in the hopes that I can “reinstall Chromium” if that’s even a thing. The reason I’m pursuing this path is because I noticed that Edge was updated on August 16th, so I suspect there’s some interference there.

Edit:
Good/bad behavior is decided upon opening the browser, before choosing a profile.
Good behavior shows profile selection almost immediately, while bad behavior takes a few seconds to load. For the rest of the browser usage lifetime, it remains good/bad.
The only thing I can throw out is that there’s some randomness factor at startup that affects all this.
I also installed un-Googled Chromium Browser and it sometimes displays the bad behavior, although far less frequently. (once) Maybe this suggests something is wrong with my harddrive/Windows?
I wish I could reinstall everything - Edge and the underlying dependencies - to see if that helps, but it seems my uninstall script for Edge is defunct and doesn’t do anything.

Thanks for chipping in.
Unfortunately, I don’t think I can utilize the developer network tab, since the problem seems to exist in new tabs, which also coincidentally take a while to open devtools.
I also tried renaming User Data like you suggested, but no changes there either.
I might peruse brave://flags and brave://gpu another day (too complicated for me right now), but I suspect that’s not where the problem is.

One of my posts right above you got hidden for spam, (Hope it comes back later) but I could randomly get good/bad behavior when I reopen Brave/un-Googled Chrome, so I don’t think it’s browser config at this point.

Shot in the dark, my speculations are:

  • Third-party applications that mess with the launch of Brave
  • Edge updates that mess with Brave dependencies (How do I uninstall Edge? For some reason the uninstall script the internet gave me isn’t working )
  • My Windows install or other low level stuff is fubar
1 Like

Alright. An update. Here’s what I observed

  • Opening Brave on a new Windows User account gives good behavior
  • Reinstalling Brave while wiping user data still retains bad behavior
  • Opening Brave in safemode gives good behavior

I decided to take a look at startup Apps

  • Exiting f.lux (v4.120) didn’t seem to be effective

The Solution? (Tentative)
I noticed that since Radeon Softare: Host Application was taking in a lot of CPU on Brave startup and new tabs, I tried exiting the Background process.
Surprisingly, that actually seemed to definitively fix the problem. Even retested on Computer restarts. I then dug into my graphics card further, and found it terribly needed updates. I updated the AMD software and driver and the problem seems to be gone!
I’m posting this late at night, so I’m not calling this solved until I have more time to test run this.

In case there’s any future person who runs into the same situation I did, here’s the rough steps I went through with AMD Drivers:

  • Open Software via clicking through desktop, and end up with a mismatch message
    RadeonMismatch
  • Consulted this forum and applied the fix in this video. Restart Comp
  • Went to the AMD site and installed the auto detector. For me it was on this page
  • Ran the auto detector. It installed a bunch of things. In the end gave me message about “Chipset Install Failed” like detailed here. It might be a false negative, I dunno, will follow up if it poses a problem in the future.
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.