New Sync Setup Does Not Start sync-internals error is SERVER_RETURN_THROTTLED

I have to reinstall Linux (was on Elementary OS 5, now scratched it and installed Elementary OS 6). I have always used Brave before so I know how to set up sync. But this time after setting up the chain, nothing happens. In fact when I refresh the sync webpage the “sync everything” and “customize sync” radio buttons will be cleared immediately, no matter which I chose.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

In a brand new Elementary OS 6 install (possibly any Ubuntu), install Brave Browser by. Launch Brave. Go to Sync setup. Enter an existing valid sync code. Select Sync Everything.

Nothing happens. Click Refresh Page. The Sync Everything radio button will be unchecked.

In brave://sync-internals I can see an error: SERVER_RETURN_THROTTLED

A screenshot can be seen here:

Reproduces how often:

Always.

Brave Version(See the About Brave page in the main menu):

1.32.115

Type of devices currently running on the Sync chain in question:

Linux Laptop (not working)
iOS 15 (working)
MacOS (many of them working)

Additional Information:

I have not tried to setup a new non-Linux machine to see if this happens in other O/S

Same error with me, i noticed the sync chain is not working for new install, both Windows 11 and macOS 12.0.1 - M1 Mac mini , other thread related to this issue.


I notice your screen has additional info: Exceed limit of active devices in a … (sync chain?)

Does anybody know what is the limit of maximum number of devices that can be added to a sync chain? I’m hoping that limit should be a pretty reasonable size, say 100 devices or even 20 will work…

I have 8 showing up in the computer that has sync working.

Hi @bryanso,
I’m not sure why it exceeded as I only have 4 devices in the chain:

Here’s the screenshot on my cMP 5,1 :
Screen Shot 2021-12-11 at 13.13.33

I already removed some of the my old devices and reinstall brave but to no avail.

I’m sure there’s something broken on their sync server not communicating with the local instance.

same with me today - I have 20 computers synced successfully but have been unsuccessful adding two more today. Tried removing/re-adding and no avail. Appears that something may be broken adding new computers to sync atm.