"New Private Window with TOR" not working

I’ve been trying to open webpages in a ‘New Private Window with TOR’ window.

The progress meter just spins indefinitely for all websites. None load.

New Private Window (w/o TOR) functioning normally.

No such problem in the TOR browser (run separately to compare).

3 Likes

Hello @mk7z

tor network (to be acurate the brave tor relay) could be blocked in your country

Tor browser has the option to change relay which unfortunatly not avaiable at leaast for now

1 Like

Thanks @justsomeone1, I use that option all the time.

I just meant it as a notification that ‘TOR in Brave’ appeared to be ‘down’ at the time of posting, whereas regular Private mode and actual TOR were functioning normally.

Just in case someone at Brave was available to look into it.

you welcome and thanks for clearfication :slight_smile:

Yo Brave Team! @mattches

This is still happening – even after quitting Brave and a full system (Mac OS) restart.

I try to open a webpage in Private with TOR tab and it just keeps trying to load indefinitely.

Just to be clear, I’m not referring to a particular webpage that’s not loading. I can’t get any webpages to load. The Private with TOR screen itself opens normally.

Brave release v. 1.21.73
OS Mojave 10.14.3

This continues today – i.e., New Private Window with TOR.

Also tried opening community.brave.com in a TOR tab in a different profile.

Same result. Tab does not load. Progress meter spins and never stops.

@mk7z,
Hello friend and thanks for reporting. Was on PTO so I’m catching up on a lot today – will look into this shortly, thanks.

@mk7z,
Actually, to confirm, you’re saying that the tab you attempt to open doesn’t load, right? When you launch a Tor window using the context menu, it should open with two tabs – one with the link you’re trying to open, the other with the NTP, like so:

Notice that I have to wait for the Tor connection to complete before the tab will load. Can you check and confirm that the connection does initialize properly?

Thanks, @mattches.

What happens is the following:

I open a New Private Window with TOR (from the ‘File’ dropdown menu option).

The window opens normally.

I then enter the URL for a website. So far, I’ve tried maybe half a dozen, including community.brave.com.

In all cases the progress meter (in the URL line) spins indefinitely and the webpage never loads.

To ensure it’s not just an abnormal delay, when this occurs I leave the tab for several minutes and then come back.

Still no loading. Still see the ‘trying to load’ spinning circle in the URL line.

Since I first reported this there’s been no change. I’ve instead used the TOR browser, without any issues.

(New Private Window with TOR is an option that I use all the time, so this is definitely unusual, especially considering that it’s persisted through a system (MacOS) restart, which often seems to fix issues.)
. . . . . . . . .
Little while later…

Just noticed that with any URL I put in the location field, as soon as I press Return/Enter an exclamation point appears to the left of it which, when I click on it, displays a ‘connection not secure’ message.

Also, shields icon shows that shields are down. (Maybe that’s normal – i.e. Brave’s shields aren’t active when in a TOR tab?)

@mk7z,
If you open a new tor window and scroll to the bottom of the NTP you land on, do you see the initializing complete (100%) in the Tor status section?

@Mattches I never even noticed that before. Would it not perhaps be better placed at the top of the page?

Also, how does one get disconnected from TOR in Brave?

image

2 Likes

had the same problem, I updated and now it works again
check if you’re using the last version, cuz it was likely fixed

1 Like

@mk7z,
Have you updated to the latest build (v1.23.73)?

@mk7z,
Also, when you launch a tor window, do you see it listed on your OSs Activity monitor?

1 Like

@mattches Haven’t updated to that version yet. I’ll do so later (when I don’t need my Private tabs, which I do at the moment).

TOR lists in Activity Monitor:

“Disconnected” still displays at the bottom of the TOR window webpage.

Looks like the issue is likely to be resolved with the update.
Thanks, @mlchatnoir.

@mlchatnoir Thanks but updating does not seem to have worked in my case.

@Mattches Updating did not work for me. TOR window still not working. TOR status still displays “Disconnected.”

If in your last question you were referring to a TOR window in Brave displaying in Activity Monitor, how would I recognize that? (In my reply I was referring to its displaying an entry for the TOR browser, which I’m having to use because the TOR window in Brave isn’t working. I didn’t see anything in Activity Monitor that appeared to be for a TOR window in Brave.)

Question re updating Brave . . . When I do it I never seem to end up with the most current version. So I get another prompt to relaunch a second time (screenshot below). The current version (1.23.73) is from 4/22/21 (three days ago). Why did the update not install that update instead of apparently one slightly previous to the current one (1.23.71)?

Thanks.

@mattches 4/25/21 UPDATE:

As noted, TOR window still not working in Release version following update, which for some reason only updated to 1.23.71 instead of 1.23.73.

TOR window functioning normally in Beta version.

i indicated that my TOR had been fixed with the update, but since today it’s broken again, so maybe it’s not linked to the version

1 Like

> today it’s broken again, so maybe it’s not linked to the version

Thanks for the heads up.

@mattches Just to summarize, my current status re this is:
– TOR window still not working in the Release version;
– TOR window working OK in Beta.