[new preference] disable hover preview for private tabs



  1. downloaded and installed Brave
  2. opened some regular tabs (gmail, amazon, etc)
  3. opened new private tab via keyboard shortcut (⌘ + ⇧ + P)
  4. accidentally discovered tab hover preview feature (pretty cool!), then hovered over private tab

What I expect:

  • tab highlights to indicate hover, but does not preview since the tab is private

What happens:

  • private tab previews, and I don’t think it should. I think this compromises the “privacy” a bit.

System Info:

macOS Sierra 10.12.5
macbook pro 15-inch mid 2015

Brave Info:

Brave: 0.16.9
rev: fba98fcb091b3abfa18aba7c6c0db0c7aa343589
Muon: 4.0.3
libchromiumcontent: 59.0.3071.86
Node.js: 7.9.0
Update Channel: dev
os.platform: darwin
os.release: 16.6.0
os.arch: x64

Screen Recording:


Hi @spicyfknrob,

There’s a setting in about:preferences#tabs to show tab preview in hover. You can switch it off. But it will disable tab preview not only for private tab but also regular tab.

Are you asking about disable tab preview for private tab but enable it for regular tab?


Hi @spicyfknrob,

You can read more about private tabs and what they do here https://github.com/brave/browser-laptop/wiki/What-a-Private-Tab-actually-does.

Like @eljuno said preview can only be turned on/off and it works same for all tabs (normal/private/session).


@eljuno thanks for the reply – I was aware of the option to disable the tab preview hover, but I’m looking to disable for only private tabs.

@sriram thank you as well. I’m familiar with the concept of private browsing, and that nothing is really “hidden.”

My use case here is that someone else (coworker, family member, etc.) walks over and the user could accidentally mouse over a private tab and expose that tab. I would prefer to have to actually click on a private tab to show its contents, since it’s private. I can see the counter-argument of “use your head” or “if it’s that important, open a different browsing window.”

This is just one user’s opinion after all :wink:



closed #5