New Chrome Brave will not import cookies, passwords (used built in), bookmarks, more from old Brave

bug
#1

Description of the issue:
This new format here is giving me another set of problems. Sorry if I have not expressed my trouble the way it is supposed to be done. Bit frustrated at the moment. I cannot tell if this post has even been permitted. Assuming it has, here are the details of the problem. Old Brave version information is:
Brave: 0.26.0
V8: 6.9.427.23
rev: de4ff2d6931c2b9784fbe5227325cd47f21a3417
Muon: 8.1.8
OS Release: 6.1.7601
Update Channel: Release
OS Architecture: x64
OS Platform: Microsoft Windows
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 69.0.3497.100

When I use use the “import” setting to import bookmark, cookies, passwords, etc., the whole list provided, almost nothing gets imported. For password saving, I used the built-in password keeper in old Brave and did not use any of the password extensions offered.

When I click the up-pointing arrow in the red circle (upper right hand corner) there is a notation that says “Brave is out of date” and it further says that it cannot update and then gives me the option to re-install the new Brave. It looks like this option might correct whatever has gone wrong, but…

Since I just spent a bunch of time installing the MetaMask extension, used the seed phrase to reconstitute the wallets, input all the token contracts, etc. I am afraid to wipe all that out by re-installing the new Brave.

At the same time, under “about Brave”, it tells me: " Brave is up to date - Version 0.57.18 Chromium: 71.0.3578.80 (Official Build) (64-bit)".

Can anyone tell me if I will lose all the work I did with the MetaMask extension by re-installing new Brave?

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Brave Version(See the About Brave page in the main menu):

Reproducible on current live release (yes/no):

Additional Information:

#3

Continuing our conversation from Reddit:

  1. No data will import if I check all of the applicable ones. One at a time, this is the result:
  2. open tabs and windows - YES
  3. stats - YES
  4. bookmarks - NO
  5. cookies - NO (sites don’t recognize me)
  6. saved passwords - YES & NO: I can view the list but they don’t fill in when I go to the sites and when I manually fill them in, I am asked if I want to save the password.
  7. browsing history - YES
  8. Brave payments - I don’t have any to import because I could not get that feature to work in the old version.
    NOTE: The notice in the upper right hand corner telling me that the version is out of date has disappeared.

As I mentioned, our importer is clearly acting wonky and I’ll be filing an issue for this today regardless. In the interim:

  1. Awesome
  2. Excellent
  3. That’s strange - it’s usually the one thing that does get imported. What I would do instead is open Brave Muon (old), navigate to Menu --> Bookmarks --> Export Bookmarks and export these bookmarks as an HTML file. You can then follow these steps to import them into your new Brave build.
  4. Even if sites are recognizing you, do you see “cookie parity” ( :joy:) between Muon and Brave Core when you view all site cookies? In Brave Core, navigate to Settings --> Advanced --> Privacy and Security --> Content Settings --> Cookies --> All site cookies to view this list and compare.
  5. Do you have Brave set to auto-fill passwords and forums? Check Settings --> Autofill --> Passwords and Autofill --> Addresses and more ensure they looks like this (respectively):

  6. Great!

I’m also going to see if anyone else on the team has other suggestions.

#4
  1. Exporting/importing the bookmarks .html file was successful.
  2. The lists appear to have cookie parity.
  3. Both settings are on as the illustration shows. The passwords importation seems to have worked now (even though I did not change anything) because I had to sign in here and the Autofill worked.

Thank you!

1 Like
#5
  1. Not all of the passwords will autofill - just tried one and no luck. I’m going to try
    signing in to a bunch of them (the imported open tabs are requiring it for those sites to open when I select that tab in new version). I’ll copy them off the list in old Brave and fill them in once and hope they save. I’ll keep track of how many work and how many do not and let you know.
#6

Re #6: Just tried 6 sites and only one would autofill.

1 Like
#7

Looking into this right now, will reply shortly. Thanks for being patient.

#8

I saw an announcement on Twitter that there is a new release so I switched over to the new Brave and saw the arrow in the red circle at the top right. As before, the notice said “Brave is out of date”. When I click the notice, a new window opens and tells me, “Brave can’t update” and “Brave couldn’t update to the latest version so you’re missing out on new features and security fixes.” Then I get the option/suggestion to “reinstall Brave” which would wipe out (I think) all my Meta Mask work. Please advise - what is wrong that mine won’t update?

#9

@BewareTheStober
So there’s a bit to unpack here but I’ll try to be brief.
General:

  1. Updating from Muon (old) --> Core (new) will not wipe or overwrite any browsing data. Furthermore, you can run both Brave Muon and Brave core on the same machine without them interfering with one another.
  2. If you upgrade from Muon, new Brave will open as essentially a “blank slate” as you have discovered. Importer was intended to make the transition fairly easy and straight-forward.
  3. We have some articles outlining this upgrade process specifically (Community Troubleshooting guide) that you may want to at least skim.

"Brave is out of date" issue: You should definitely reinstall - I feel confident this will resolve the update issue. Although I am helping a separate user who may be having the same issue on Win 7 - might be OS specific.

Anything you’ve done on Metamask, afaik, is stored on Metamask - ensure that you have your info backed-up and any passwords/phrases saved somewhere, then you just have to install MM extensions in Brave (new) and you’re good to go.

I know that the issue with the importer is frustrating this process, but highly recommend you update to Brave core anyway - Brave Muon is no longer supported and is very quickly becoming outdated from a security standpoint.

Let me know if you can update after un/reinstalling.

#10

Hi Mattches - Thank you for remembering my dilemma and sending the solution. I am not happy with the solution, but not surprised by it.

I use Meta Mask as a conduit rather than using their internal wallet(s). I use the “loose account” feature of MM and connect to my MEW wallets via MM. What that means is that, when I re-install Brave, I will have to manually input the contract information from the blockchains for each token, something I did just days ago when I acquired the MM extension from the Google chrome store.

It is not just a restore by using the seed phrase, unfortunately… contract/token info input, new pass phrase, new back up, etc. etc. (all records of ETH gas tx fees get eradicated so that’s another manual record I need to make) The contract info must be done carefully because, once input, it cannot be changed unless they have updated that feature and I have been unable to ascertain whether they have fixed that yet.

All that is what I was hoping to avoid. It is unfortunate that I read that bit of advice regarding installing MM first prior to making any selections or imports concerning the Brave rewards feature.

Ah, well, at least I know to check that everything else is in working order PRIOR to installing the MM extension this time.

I have been using both browsers simultaneously with no problem (one is chrome and the other mozilla, right?/different cores) but the old Brave needs to be closed for the importation of data from one to the other as you are aware.

One question before I re-install: Do you know if the newly installed updated version of Brave will update going forward with no problems in Win 7? Would hate to do this repeatedly.

I’ll wait to hear your response on my question before re-installing and thanks again.

#11

@BewareTheStober,
Apologies for the late response. Worth mentioning that if you download the installer and run it, if a Brave (new) installation is detected, the installer will instead only initiate the update process - it will not be a “fresh” install of Brave unless you’ve uninstalled it (and any associated data) as well. Running the installer and updating may actually fix the update error for future updates as well. Since we don’t have a ton of data on it its hard to say at this time.

I’m very sorry for the MM debacle and inconvenience and appreciate you remaining civil and understanding (this does not come so easily for some people :stuck_out_tongue:).
For next steps:

  1. Download from our official page and run the installer - this should initiate the update
  2. It may seem silly but try running the importer again. See if you get better results. Furthermore, i’ve logged this officially so the team can get the importer running smoothly:
    https://github.com/brave/brave-browser/issues/3674

Let me know how everything goes.

#12

Do you mean that I should try running the importer again (all choices checked or one and a time?) PRIOR to the re-install?

#13

After the reinstall - although again, if you already have it installed it’s simply going to update rather than overwrite and install with fresh profile data. So DL installer, run it and (hopefully) update. Once updated (should be v0.61.51) try running the installer again.

#14

Got it. Thx. Be back when finished. It might be later as I have work obligations this afternoon.

1 Like
closed #15

Closed in favor of “master” issue below.
Even if you’ve already reported this issue before – reply here with some details about what did (or did not) get imported when they tried using the importer if you’d like to help us get this issue resolved: