Network error when summarizing specific YT video with Claude

If I try to summarize it with Claude I consistently get:
image

I understand if it’s too lengthy to summarize but it should clearly say so. I’m sure I’ve seen it complaining about too much length in the past.

Did Brave change some timeout? I keep getting “network issue” on queries on anything that is somewhat long, then I retry like 3 times and eventually (in some cases) it goes through and I get an answer back.

I used Net Exporter and found that I get this reply:

HTTP/1.1 500
date: Mon, 22 Apr 2024 07:04:12 GMT
content-type: application/json
content-length: 69
server: uvicorn
{"error":{"type" :"50001","message":"An error occurred: ReadTimeout"}}

from a POST to this url: https://ai-chat-premium.bsg.brave.com/v2/complete

Probably unrelated to the server-side 500 error, but I had Brave crash to desktop twice on me when pressing the Summarize button on this exact video to retry and see if the timeout is fixed.

Can someone please confirm whether they face at least the network issue when summarizing with claude this video?

So many network errors lately… Can anyone else confirm? Is it just me? Every big page I try to feed to Leo (claude model) gets the above network error. Sometimes retrying 3-5 times helps, other times it seems a permanent issue (like with the video I linked).

I have another case with another video (I swear I’m not that much into UFO videos I just keep noticing it on them because they are lengthy haha) https://www.youtube.com/watch?v=yzi8xcRicGE but it’s when I press “Suggest questions” this time. It fails consistently to show questions, and using the Net Exporter tool I saw that once more it’s the exact same ReadTimeout error behind the scenes. Yet for this video the summarizer works.