Netflix doesn't work anymore



Everytime I try to load a netflix serie or film it gives the following error code: M7121-1331-P7

It’s not an account or computer issue since it works fine in other browsers.
Also tried putting down all shields, same error occurs. Didn’t use to happen before. Since a few days, I can’t use Netflix anymore. Since latest update maybe?

Netflix error code: M7121-1331-P7

Please help!

Thanks in advance.

Best Regards,


Hi @TommyQ,

Related to Netflix crashing, error M7121-1331-P7, worked before and Netflix Streaming Error and this one Netflix - Video is not playing.

Thanks for reporting! It’s a known issue and the team is trying to fix it. I added your comment as +1 and you can track the progress here:

I’m also going to close the thread since the issue is logged in GitHub. If you have another question or face some bugs, please open a new one for each.

The new version is release today with the fix of this issue. Please update your Brave version @TommyQ .

Thank you,

closed #3