Need help allowing cookies for Boomerang Chrome Gmail plugin

Description of the issue:
After following instructions for allowing cookies from a Chrome plugin for Boomerang I can’t get the Boomerang plugin to work. Boomerang is very helpful to return an email that hasn’t been responded to as a reminder to email that person again.

**Steps to Reproduce (add as many as necessary):

  1. Click on Boomerang icon in Gmail
  2. Click on Settings
  3. Pop up pops up saying “login successful”
  4. 3 seconds later error message appears - ( Attempt failed: Third party cookies must be enabled for Boomerang to work, but they are not currently enabled in your browser.

Please enable them, or create an exception for b4g.baydin.com . For information on how to do this, please visit the help page for your browser:
Chrome |
4. Click “OK” button

Actual Result (gifs and screenshots are welcome!):
Gmail is back to the regular inbox and I have to start the cycle over again with Boomerang still not working

Expected result:
Boomerang should work in a newly composed email. Instead, when Boomerang is checked the “Login successful” pop up emerges. 3 seconds later error message appears - ( Attempt failed: Third party cookies must be enabled for Boomerang to work, but they are not currently enabled in your browser.

Please enable them, or create an exception for b4g.baydin.com . For information on how to do this, please visit the help page for your browser:
Chrome

Reproduces how often:
Every time I try to launch Boomerang in an email composition

Operating System and Brave Version(See the About Brave page in the main menu):
Version 0.67.124 Chromium: 76.0.3809.100 (Official Build) (64-bit)

Additional Information:

I have the exact same problem. It’s 100% repeatable.

I thought lowering the shields on Gmail would make Boomerang work, but it doesn’t.

However, toggling the different site-specific shield settings, and then setting to allow cross-site cookies seems to have fixed the problem. This seems related to Brave Shields Not Working?

I’m having the same problem. I would like to continue to use Boomerang but I can’t get it to work.
I’m concerned about "allow cross-site cookies’, doesn’t that defeat the point of Brave in the first place?
Just to clarify, (@danieljlewis), did you mean the Brave’s “Settings” --> “Shields” --> “Cookies” --> Changing “Only block cross-site cookies” to “Allow all cookies”?

Does that defeat the point of Brave to allow all cookies?
Is there a way for Brave to allow specific extensions, like boomerang to have exceptions? At the moment it doesn’t seem like it?

Last question, if my concerns about ‘allow all cookies’ are true AND it’s the only way to get boomerang to work, is there an alternative to boomerang that works within Brave along with all the safety features of Brave?

Thanks for your help,

I mean to toggle the settings on and off in the website shield (for any site) in the address bar. That seemed to fix it for me for all sites, but toggling the options in the browser settings didn’t do it.

Think of it like re-aligning the flux capacitor or something. :slight_smile:

@DanielJLewis,
This is correct – you can resolve the issue by changing your Shield setting sin the address bar, as they apply on a per-site basis.

That’s not actually what I’m referring to. I mean toggling all the options off and back on again (or swapping options) on one site fixed my issues for all sites that were having problems.

@DanielJLewis,
When you toggled them off/on/swapped, do you do it here:

Or here?

Hi DanielJLewis,

Thank you for your responses. Can you take a screenshot of what you’re referring to with all the options? I thought Mattches screnshots of the brave "toggles’ was what you were referring to but I’m confused when you said “toggling all the options”, because the screenshots Mattches provided was the screen from the Brave Icon on the Brave browser.

Has anyone found a way to provide a local exception to “B4g.baydin.com”?
I can’t find a way to ask Brave to make a specific exception.

Thanks for your help,

Sam1

The first one. The Brave site Shield for any site (it doesn’t have to be one having problems).

@Sam1, when I said " toggling all the options off and back on again (or swapping options)," I meant going through each one of those options in the Brave site Shield. If it’s an on/off toggle, switch it and switch it back. If it’s a drop-down, change it to anything and then change it back. The result will look like you did nothing different. You’re basically “jittering” the options. But this must have reset some corrupted options for me, because doing that on only one site, fixed the weird Shield-like problems I was having on all sites.

For example, if I was having the weird problem on a.com, b.com, and c.com, I could go to a.com, “jitter” the site shield options as I explained, and then b.com and c.com magically worked correctly, too.

Thanks for your fast reply.
I went ahead and did that and it still didn’t work. I wish Boomerang would comment on this.
I’m open to other ideas.
Thanks again

Trying to make Boomerang work? Now that you’ve “jittered” the settings, try lowering your shields completely on Gmail.

@DanielJLewis,
Unless there’s a particularly significant issue with Shields, the effectiveness of the “jittering” technique you described is likely just a coincidence. Is there a set of steps and sites in which I can test myself to confirm that this behavior (“jittering”) occurs as you report it?

@Sam1 @pacificananda,
On my end, I was able to simply install the Boomerang Gmail extension and start using it immediately:

For anyone having issues with the extension, would you mind trying to clear your gmail cache/site data, relaunch the browser then try installing the Boomerang extension again (note that you’ll have to re-authenticate into gmail)?

A note about Boomerang, I think I had to change the site Shield settings on Gmail to allow all cookies for Boomerang to work:

@Mattches, please note the troubleshooting steps I previously tried, including incognito windows, changing shield default settings, disabling site shield, even completely reseting Brave, but nothing worked until I “jittered” those site-specific settings on only one domain, and then all the other sites that I mentioned had problems immediately stopped having the problems I documented here. I know it sounds weird, but based on the troubleshooting steps I followed, this one actually worked.

@DanielJLewis,
Thank you for the information – certainly strange behavior (even though it caused something to work rather than break) you’re seeing. I’ll have to do a bit of digging and see if I can find a way to reliably reproduce the error.

Thank you for your help!

My theory is that my shield settings were somehow corrupted and they weren’t being reset by default shield settings or by even resetting Brave. But “jittering” a single-site Shield settings might have overwritten a corruption.

I see it sometimes with other tools where simply resaving (or changing something in order to force a save) corrects some kind of corruption.

1 Like

Reposting Sam1’s query because it seems to have been ignored…and I’m not able to create an exception just for Boomerang.

Plus I’m posting so this topic isn’t closed tomorrow. (Dear Brave Forum Admin: A 2-month time-out is way too short for useful and unresolved threads. I hope you’ll let these threads live a bit longer before closing them.)

@Curtis,
Can you try going to brave://settings/content/cookies, scroll down to the Allow section and add the cookie you need to this list?

I think that worked! Previously I had to set it to All Cookies Allowed. Now with that exception I’m able to reach the Settings page for Boomerang.

But now Gmail is giving me the “Gmail is having authentication problems. Some features may not work. Try logging in to fix the problem.” message any time I have Cross-Site Cookies Blocked for Gmail. I don’t want to hijack the thread and will attempt to research further.

1 Like

That did it! Thank you, @Mattches. I missed finding that page during my first couple of trips through settings, so I googled it and ended up at this thread. Thanks for clearing this up!

1 Like