Native notifications enabled, chrome notifications still used

Description of the issue:

I have enabled the enable-native-notifications flag in Brave, but Brave still uses its custom Chrome notifications. I’m using dunst on X11 and i3.

Steps to Reproduce (add as many as necessary):

  1. Install dunst
  2. Enable native notifications with Brave in brave://flags
  3. Restart Brave (and computer)
  4. Test notifications on Brave

Actual Result (gifs and screenshots are welcome!):

Chrome-themed notifications are displayed, not the native dunst notifications

Expected result:

Dunst notifications should be displayed, as is expected when using native notification support

Reproduces how often:

Always. On a previous installation of Linux (last week), clearing Brave’s ~/.config folder and then enabling the flag seemed to solve the issue. But that didn’t solve the problem this time :(((((

Operating System and Brave Version:

Gentoo Linux 4.19.44
Brave Version 0.65.116 Chromium: 75.0.3770.38 (Official Build) unknown (64-bit)

Edit: Additonal information:

I found this in the log when I start Brave and thought this might be helpful for solving the issue:

[30054:30134:0612/224910.031905:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")