My region is not accepted even though I provided documents that I am a citizen of the US

Briefly describe your issue:
My regions denied even though Brave policy states that region is determined by the documents used during verification. I used US documentation. However, I work in Asia most of the year.
What Operating System and Brave version are you using (Menu --> About Brave)?
Windows 10//
Version 1.50.121 Chromium: 112.0.5615.138 (Official Build) (64-bit)

Is your browser wallet currently verified? (yes/no)
Yes- Uphold
What date did you verify your wallet?
Verified on 05/27/2020

Ok, so I’m a bit confused here and hope you can clarify. The topic and text above makes it seem like your region is denied. But then you say here that it’s connected. Obviously this information contradicts itself. Am I safe in thinking that you’re saying it was connected before but you’re now unable to connect the browser?

Anyway, let me ask you some questions:

  • What is it saying or doing that you’re saying you can’t connect? (type of message is helpful. Can even provide a screenshot for clarity)

  • What region do you have chosen for your operating system? For example, if you have it set for Japan then it wouldn’t show Uphold or allow you to connect, as Japan is Bitflyer only. Again, I’m speaking about the region for your OS and not for Brave in this question

  • Which country did you choose for your Rewards country? If you don’t remember, you can check it by going to brave://rewards-internals to check what it says for Rewards Country.

If you chose Asian country but used US documentation, then it would say Country Mismatch. The county you choose for your Rewards must match your documentation used for KYC/AML.

Thank you so much,

I answered directly below for clarity:

  • What is it saying or doing that you’re saying you can’t connect? (type of message is helpful. Can even provide a screenshot for clarity)
    My error. In the past, I was connected. I was connected and receiving rewards ,then it stopped. I reached out to Uphold and provided proof of residence and citizenship in the US. The rewards continued. Now they stopped again.

My uphold account is set to the US region via documentation.

  • What region do you have chosen for your operating system? For example, if you have it set for Japan then it wouldn’t show Uphold or allow you to connect, as Japan is Bitflyer only. Again, I’m speaking about the region for your OS and not for Brave in this question
    *My OS is set up for Taiwan. I have full access to uphold.
  • Which country did you choose for your Rewards country? If you don’t remember, you can check it by going to brave://rewards-internals to check what it says for Rewards Country.
    I copied and pasted you suggestion in my browser :

Rewards info

Key info seed: Valid

Rewards payment ID: a9593867-90fd-4206-8928-ca5273fde782

Rewards profile created at: 05/26/2020, 07:36:41 AM

Rewards country: US

So both Brave and Uphold have my region as US.

Thank you for your time.

@Cryptopsycho21 you didn’t answer this question. It is important to know what you’re seeing when you try to connect. Are you able to click on Uphold and attempt to connect from within Rewards? Or what’s going on?

I have some assumptions based on what you’ve said, but unfortunately you’re not explaining or showing what’s happening. Once you get this final piece of the puzzle to me, I can give you an answer.

You need to remove your Rewards payment ID never post that

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.