My Recent Frustrations Using Brave Browser

I am currently using iPhone 12Pro, 11Pro, 8, iPad(7th Gen) and Apple Watch Series5 with Brave browser/DDG set as default browser/search across the board. All devices are updated to iOS 14.4.1 with watch running WatchOS 7.3.2. All applications are updated. I use iPVanish most of the time but have not been able to keep that set for On Demand lately due to reasons I will mention in a minute. I’ve been a supporter and user of Brave browser almost since inception, long before iOS 14. However, I am now seriously considering a complete walk away from Brave because I’m sick of the daily frustrations that seem to come along with using Brave. Approximately 50% of all Siri searches simply will not load and 100% of Siri searches directed to YouTube are met with a Google block stating "Our systems have detected unusual traffic from your computer network. Please try your request again later.” I can’t begin to say how much I have grown to hate that notification. When browsing the web using Brave without Siri, it appears that approximately 30% of the results given by Brave and/or DDG either take several minutes to load or an error code comes up. My settings in Google, Gmail and YouTube shackle Google as much as is possible from tracking me, monitoring location and targeted advertising. My settings in DDG are customized, checked regularly and cloud saved. I do regular and complete maintenance on all devices that includes clearing the RAM, website data and search history. It seems like Brave Browser has been getting worse and worse lately instead of improving. It actually pains me to say that because I have been a strong proponent of Brave to anyone who will listen to me. Am I missing something? I was hoping that one of the community’s experts or possibly someone from Brave could point out what I should be doing to avoid these issues or recommend something that would help. Please advise.

@MidNiteRaider hi, unfortunately I’m not an ios user so I have no idea why you are experiencing this issues.

This is the only thing I can do for you: @Mattches @fanboynz @Aa-ron @sampson

1 Like

So what I’m hearing your say is that using search w/Siri doesn’t work many times and if one does work but lands you on Youtube, you get flagged for “unusual traffic” – is that correct? Further, based on:

:point_up: searching in the browser using DDG works, but often takes a long time and/or will eventually give you an error.

I understand that you are very much trying to prevent yourself from being tracked but the question I’m left asking after all of this is whether or not you get the same behavior if you have IPVanish disabled?

1 Like

Thank you for responding, With VPN disabled, all Siri searches that are directed to YouTube receive the same error code, but not if I start a search from Brave/DDG. You Tube opens in that case. Seems odd because the Siri searches go through default browser(Brave).
Of course there are always certain sites that won’t open with a VPN, but I have found iPVanish to be one of the least blocked of the many I have used. There must be a work around to stop the “unusual traffic” codes. Of course I have tried complete power down and restarts as well as clearing RAM etc., Ive tried many different combinations… Nothing has worked. Interesting note, the blocks do not not occur if I use the DDG browser as default.
Also, when searching from Brave directly, I often get "page couldn’t be found” codes or 404’s. Many times if I disable the fingerprint shield on Brave, sites will open. I don’t like disabling Brave’s default shields.

Can you tell me how you have your default Shields settings configured?

1 Like

I usually keep the Brave default shields up, That is, all shields up except 'block scripts’ and ‘Block all cookies’

I missed where you said

This makes sense to me – however, can you confirm if this always works? I know you’re hesitant to disable any protections, but it will go a long way towards narrowing this whole issue down. Further, if it is Fingerprinting, I can inform the Shields team that it’s conflicting with certain sites/actions and have them take a look.

Disabling the fingerprinting is successful most of the time, but I can’t say always. When taking down that shield doesn’t work, I will occassionally hit the toggle that disables all shields just to see if the site will open. However, I do not leave all shields down any longer than it takes to find that out. Subsequent to that action, I will usually close all tabs, delete all website data and search history, get out of the browser and restart the device. Some might see that as an overreaction but I personally find it quite invasive and creepy when I come across a site that requires that action just to open.

I only see this error when using a VPN, google has magic sauce that sometimes kicks in. Where it would redirect you to captcha before completing a google search.

Disabling the VPN would be first step, and also trying in private mode.

1 Like

This sounds exactly what I would expect when using a VPN. VPN assign the same outgoing IP address to many users simultaneously. This is often detected as some kind of DDOS attack by websites. This is “normal” when using a VPN. You should however not see this error message when connecting without using a VPN.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.