My brave "Add Site" button isn't working?

When ever I click the “Add Site” button for adding favorites websites on brave desktop, It opened but didn’t work. Whenever I tried to save a website and click on “save” button, It didn’t add the site in the bar.

1 Like

i have the same problem and still don’t know how to fix it… :frowning:

@AliHassan and @Xris_666

This is just a glitch in the recent update. It’s actually appearing “underneath” so when you go to click, it’s hitting the page that’s on top of it. The workaround at this point in time is not to click. So hit the button to Add Site but then you just used your keyboard to type things in, Tab to switch between the Name and URL bar, then hit Enter for it to accept.

2 Likes

Thanks a lot, it worked out. But when brave will resolve this glitch.

Hey it no longer works when i press son add url the whole thing disappears and it only allows to name the add site

That is what we referred to above. You cannot click on anything you can only tab and enter.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.