Multiple speedtest sites fail on upload


#1

I have noticed that Fast.com and Speedtest.net both fail to connect on their upload testing. Chrome has no such issue.

Win7 Pro Brave Version 0.57.6 Chromium: 71.0.3578.31 (Official Build) beta (64-bit)


#2

Just tried both your links. On Fast you will only get download speeds until you navigate to this page and check the option ‘always show all metrics’


Speedtest gave me the expected results.
Hope this helps.


#3

All I got was a “Could not reach our servers to perform the test. You may not be connected to the internet”. Only after disabling all Brave Shields did Fast,com work properly.


#4

Were you blocking scripts or blocking all fingerprinting? This may have caused the issue. Additionally, speedtest.net is not a secure site, so if you have https everywhere enabled this may cause conflicts as well.


#5

Capture

That is the settings that is causing the issue.


#6

Works just fine for me with replicated settings:

Tested in Beta and Release builds. Do you have any additional security extensions installed that may be blocking uploads from the test?


#7

Well something then has to be screwed up with Brave then since if I disable encryption and change it to All Device Recognition Allowed it still fails. It only works if I use the top slider and disable it completely. Unless there is an issue with the Netflix server in Toronto that the site is attempting connection to.

Sigh yet another thing to add to my list of things that doesn’t work properly in Brave


#8

@kbounds56, myself, and a few other team members I reached out to are also able to do this (same Shields settings) without issue.

Given that you seem to be the only one so far to encounter this, it may be worth considering that it’s not an issue on our end, an may be something specific to your machine, your config, or your connection. This is why I asked if you have any additional security extensions/software that may be monitoring/blocking this type of activity.


#9

The thing is that if it was something else affecting this page then why is it only Brave having the issue. Chrome has no such problem. I have 100/100Mbps connection via fibre connection here. I have Eset NOD32 and Malwarebytes but both of them are monitoring every app including Chrome. Your demo showed the first slider button for Ads and Trackers blocked. I don’t have that enabled and I am connecting to a different server. My test is connecting to Netflix server in Toronto Canada.


#10

I just checked another system here Win10 Pro and no NOD32 and it too has the exact same issue with the same Toronto based server.


#11

I’m really not sure what to tell you about it;

Speedtest also worked

I’ll leave this thread open in case anyone else is encountering this. I’ll also ask around some more and see if I can find anything on our end.


#12

Perhaps its best just to uninstall Brave completely here and trash its data directory. This is happening on multiple computers and 2 different Windows os and the only commonality is that with Fast.com is that its hitting the same Toronto server and I can not change that.


#13

Try testing on a few other speedtest sites that may let you change where you’re being routed through.
Here are a few examples:
https://speedof.me
https://speedsmart.net/
https://testmy.net/


#14

speedof.me ran fine in Brave so did testmy.net

However speedsmart.net failed in Brave. I tried 3 different servers. Every time at the Download test the test never showed any numerical value for the test in Brave. All that happened was the progress bar for the download test continued to scroll off the right hand side of the page. I also noticed that the horizontal scrollbar in brave also was changing in real time indicating that there was lateral scrolling action being done. Speedsmart in Chrome had no such issue even with the default Chicago server.


#15

speedsmart.net works fine for testing download speed on my system, but the upload speed test fails with tons of JavaScript errors like this one in the console:

Access to XMLHttpRequest at ‘https://se.veeapps.com/upload.php?r=0.6727424207304831’ from origin ‘https://speedsmart.net’ has been blocked by CORS policy: Response to preflight request doesn’t pass access control check: Redirect is not allowed for a preflight request.

With shields down, both download and upload speed tests work fine, so I guess the validation is stricter when shields are up?


#16

@jek6094 thanks for the input.
This is not unexpected behavior, given that the test implementation may differ site-to-site. For example, speedsmart.net looks like it requires cookie access in order to complete the upload. If you select Allow all cookies from the Shields panel for the domain, the test should run as expected.

Its important to remember that given our focus on security, our protections will sometimes break a website or prevent functionality. This isn’t [necessarily] indicative of the browsers inability to perform some task - the majority of the time its indicative of a conflict between some website function and Shields. This is why we offer the ability to set protections on both a global and domain-specific level.

@fedup, go to speedsmart.net, allow cookies, run the test. Should work fine. @jek6094, same thing.


#17

Confirmed, by allowing 3:rd party cookies in the shield, the upload test works fine! :slight_smile:


#18

Here allow all cookies was and has been enabled for days here due to all these issues. If I disable Shields entirely then the test runs fine.


#19

Your Shields panel looks like this


And you’re still unable to complete the speedtest?


#20

Well I nuked Brave Beta out of Windows7 and then to ensure everything pertaining to Brave was also removed I deleted any and all Brave Software folders. I then downloaded the beta and installed it. Both Fast.com and http://speedsmart.net/ both function properly once I allow 3rd party cookies. This is before any of the extensions that I have installed in Chrome are installed in Brave. However at one point prior to nuking brave I had gone into Brave and disabled ALL of my extensions, reloaded the site pages and they still would not function properly even with 3rd Cookies enabled. They would only work as I previously mentioned if I disabled Brave Shields entirely.

This seems to indicate that there was a setting elsewhere in Brave that was causing this issue and was not related to Windows7.