Multiple sound device issue

  1. Switching audio devices keeps the browser stuck on the first audio device in the list. Restarting the browser or the system does not help.
  2. Disabling and enabling sound in brave://settings/content/sound resets this behavior and makes the browser correctly use the devices selected as primary in the os.

Brave version is: v1.40.113 (July 5th, 2022)
Os is Fedora 36 fully updated.

Hi @Riotvan , can you give an example site/web app (for example Google Voice, Zoom, or similar) where this can be seen?

And by switching audio devices, I assume you mean changing between something like built-in speakers and a Bluetooth headset?

Lastly, do you happen to also have Chromium or Chrome installed? Wondering if this issue might be upstream, but I should be able to do some testing on my end once I know I’m using similar conditions.

Hi, it happens with whatever site uses audio. Youtube, Facebook etc…

My setup is as follows i use an Apogee Groove usb headphone amp and also an addon soundcard(Digigram VX-222e) connected to a speaker system. But it also happens if i switch to the integrated speakers on my display.

It does not happen with Chromium or Firefox and i’ve tried resetting Brave by temporarily renaming the folder in .config. Switching devices during mid stream switches the sound over to the new device immediately on these browsers as well.
Only thing i did that is different from stock is increasing the resample quality in pipewire from 4 to 10 and adding support for 44.1khz which was added in a recent version which i have installed. But the other browsers work fine with this and i’m pretty sure i tried disabling these settings.

System:
Ryzen 5900X 32GB
Asus B550-E Gaming
RTX 3080
Bunch of nvme and sata ssd’s
Fedora 36 on wayland

Let me know if you want more details.

Hi again, haven’t forgotten about this, just haven’t had time lately. Will see if I can get to it this weekend.

1 Like

@Riotvan , still didn’t get a chance to test this yet. But saw this just posted: Brave audio going to new audio device regardless of apparent settings

Does the workaround described there help in your case at all?

Hi, yes this workaround works. I thought pavucontrol was deprecated due to the switch to pipewire.

1 Like