Multiple device user not able to get all rewards

Briefly describe your issue:

Have brave Brower on 4 devices
Razer touch screen laptop
Windows 10 gaming pc
Windows 10 streaming pc
And Samsung 10 edge mobile device

On the mobile device and on the streaming pc. I have recieved my rewards
On the GAMING pc. I was given the same (you will recieve your rewards in 7 days ) message and the timer worked. But when the timer ran out… initially only the streaming pc was given a claim link
It worked
Then the razer laptop recieved a link to claim about an hour later
I was unable to use the touch pad or a regular mouse in order to drag the brave icon into a circle square or triangle
I still , 12 days later have the claim button on my laptop but it will not register the security code of drag and drop

The mobile phone recieved the claim button a bit later , but would not claim either

I would click claim and it would just start timing out.

I tried a half dozen times or more and then left it
In the morning my mobile device had finally recieved the rewards

Now I have recieved 2 of 4 device rewards

The gaming pc however did not recieve any claim button nor any notification of receiving the rewards or not

And the will claim in 7 days timed out by its appropriate time

And the laptop is still unable to drag and drop verify…

Please help
Thanks

What Operating System and Brave version are you using (Menu --> About Brave)?

Is your browser wallet currently verified? (yes/no)

What date did you verify your wallet?

Have you been able to successfully receive payments in the past?

Are you using a VPN? (yes/no)

Are you in a supported region (see here for list of supported regions)?

Does your device pass the SafteyNet check (Android only)?

Have you manually turned off Auto-contribute on all of your devices linked to Uphold??