Most recent version (0.19.139) of Brave crashes on launch


#1

How might I reload the most recent previous edition? Thanks


#2

What’s your OS?

Thanks,
Lauren


#3

Hi Lauren:

Macintosh OS X, version 10.9.5

Thanks.

Bob


#4

Would you mind trying this before reverting?

Close Brave.
Navigate to ~/Library/Application Support
Rename the brave folder to be brave-1
Relaunch Brave

I’m wondering if it still crashes with a clean profile.

Thanks,
Lauren


#5

@Taquinas - a user on another thread reported the above steps didn’t work for them. Here’s how you can go back to the previous version:


#6

Logged https://github.com/brave/browser-laptop/issues/12744


#7

Great – thank you Lauren! I’m decidedly not a tech jock so this is very helpful.


#8

PS - it crashed again on opening. Just before that, I attempted to respond to an email and the text box was blank with one line of text at the top unrelated to the message. I will try again tomorrow.


#9

Please see the note above @Taquinas - if you have any logs that could be of assistance we’d appreciate it :slight_smile:

Lauren


#10

This is also happening to me. I have a mac running version 10.9.5. Did the update yesterday and now Brave crashes and freezes. I did the fix you suggested for funkycid (download older version) and that works TEMPORARILY. As soon as I log out of Brave, I get a message notification that Brave has quit unexpectedly. Clicking on “reopen” does nothing. Clicking on my Brave quicklink on the taskbar only brings up the error message. Checking the Brave application in Finder reveals that it has reverted back to the latest version (0.19.139) even though I deleted it as per your instructions. Any other ideas for a fix?


#11

I don’t find any .dmp flies. I can’t get anything related to Brave open.


#12

Yep. Same problem here. The newest Brave won’t start on 10.9.5.

But 0.19.134 from the archive works.

But I deleted everything related to Brave before installing it…

Edit: after a few restarts of Brave it will not start again. At first the helper app was crashing and I can’t get out of an error message loop. I had to kill Brave first. And then it crashes again shortly after starting it.

When I drop the 0.9.134 from the disk image again, it starts. Let’s see how long :wink:

Edit 2: It crashes again and again …


#13

Hello! Same issue here running 10.9.5

Bad thing is I started the process to receive the BAT you were giving away before the update and I don’t know If they will be allocated now that I deleted the complete installation including all plist files and everything (I used app cleaner in hopes to reinstall and have it all again) but still crashing.

Downgrading and seeing if the tokens are still there!

I do have the crash files if anyone needs them.

Bravo for the great software!


#14

Hi Lauren;

I went back and tried this again-- it worked! I hadn’t fully deleted the more recent version.

Many thanks for your assistance - I really appreciate the Brave browser.


#15

Hi @greencross

Would you be able to put the .dmp files onto Google Drive or Dropbox and private message me the link? I can share with development for review.

Thanks!
Lauren


#16

@Dinkster so 0.19.134 is also crashing on you?

Lauren


#17

Yep. Sadly :wink: I fetched .133 and this version’s working … untill this morning.


#18

It sounds like going back versions messed up your profile. You can try a clean profile by closing Brave, navigating to ~/Library/Application Support and renaming the ‘brave’ folder to something else (brave-1 is fine) and then relaunching 0.19.134 (or 0.19.133 if you rather).


#19

I believe one of the issues is the internal update mechanism (ShipIt) failing to either complete successfully or failing to log it properly, so each time Brave is run it sees a scheduled ShipIt process to complete and then crashes. Here’s the console debug output, OSX 10.9.x:

1/20/18 4:25:54.752 PM ShipIt[2214]: Moved bundle from file:///Applications/Brave.app to file:///var/folders/6n/j3myh_zj3bj4wshtl6vpv22w0000gn/T/com.electron.brave.ShipIt.lCmQphu1/Brave.app

1/20/18 4:25:54.752 PM ShipIt[2214]: Moved bundle from file:///var/folders/6n/j3myh_zj3bj4wshtl6vpv22w0000gn/T/com.electron.brave.ShipIt.Wr78DVgk/Brave.app to file:///Applications/Brave.app

1/20/18 4:25:55.904 PM ShipIt[2214]: Couldn’t remove owned bundle at location file:///var/folders/6n/j3myh_zj3bj4wshtl6vpv22w0000gn/T/com.electron.brave.ShipIt.Wr78DVgk/Brave.app, error NSError { domain: NSCocoaErrorDomain, code: 4, description: ““Brave.app” couldn’t be removed.”, failureReason: “The file doesn’t exist.”, underlying error: NSError { domain: NSPOSIXErrorDomain, code: 2, description: “The operation couldn’t be completed. No such file or directory” }, userInfo: {
NSFilePath = “/var/folders/6n/j3myh_zj3bj4wshtl6vpv22w0000gn/T/com.electron.brave.ShipIt.Wr78DVgk/Brave.app”;
NSUserStringVariant = (
Remove
);
} }

This happens whenever I manually replace the 19.139 app binary with 19.134. So Brave is still stuck in an upgrade loop. Where is the ShipIt task log? If that can be cleared, then downgrading will work and shouldn’t affect the user profile.


#20

@extrarice - does this answer your question about ShipIt ?

Thanks,
Lauren