Monterey 'tap jump' shortcuts error

Brave Version( check About Brave):

Brave latest v 1.31.91 Chromium: 95.0.4638.69 (x86_64)

Additional Information:

Hello, this Topic is totally same with me.

Just only one thing difference is my MacOS is Monterey.
but that guy was Big Sur.
I’m sure this is Bug of Brave.
because, Safari browser have works right.

what can I do?

tap jump
Jump to the next open tab ⌘ + Option + Right arrow
Jump to the previous open tab ⌘ + Option + Left arrow

Does the macOS version of Brave have this, or similar, in Settings?

“Cycle through the most recently used tabs with Ctrl-Tab”

If so, and if it’s enabled, try turning it off and see what happens. Your issue sounds very similar to what I think is a known issue where the original Chromium shortcuts got broken when this feature was introduced.

If that doesn’t help: if you have extensions installed, try disabling all of them.

Hello JimB1, thank you for your reply.
I checked what you said.

(1) Does the macOS version of Brave have this, or similar, in Settings?
If so, and if it’s enabled, try turning it off and see what happens.
⇨ I checked every shortcuts on my Mac.(mac setting > keyboard > shortcuts(…))
but I can’t found any problems.

(2) If that doesn’t help: if you have extensions installed, try disabling all of them.
⇨ Yes I did it too. but there are nothing as well. it is normal.

So, I still can’t found any solution.

And, I found important one!

  • Brave > tap > jump to next tap
  • Brave > tap > jump to before tap
    When I click this memu, It works like error(tap moved random)!
    I mean, I thought this error is ‘Shortcuts problem’ before.
    but I realized this issue is problem of browser. Because if ‘Shortcut problem’, when I directly click ‘Brave > tap > jump to next tap’ menu, It should work correctly.
    But when I order by Shortcut or directly click mouse, it is same result that ‘Tap moved random’ so this is not problem of Shortcut key.

This has been my diagnosis so far.
I still don’t know how to resolve it.
:sob:

Hi, thanks for checking. The setting I was talking about isn’t in Keyboard Shortcuts though, it has its own entry in Settings.

So if you go to brave://settings/ and then search (⌘ + f ?) for ‘cycle’ you would see this, at least in the English version on Windows:

image

Sorry, I’m not really sure of the best way to translate all of that. But it has its own setting that is not part of the ‘Keyboard Shortcuts’ settings.

This is where it got introduced into Brave, but unfortunately also delivered some bugs for existing keyboard behavior. https://github.com/brave/brave-core/pull/4671

1 Like

Wow. That worked!! :slight_smile: Thanks both of you.

2 Likes

It’s worked too for me!


I found what you said, by Korean ver, setting
“Ctrl-Tab을 사용하여 가장 최근에 사용한 탭 순환”

JimB1 you are my HERO. :star_struck:
I really want to say THANK YOU!

1 Like