Mojave Beta - Browser Force Closes when attempting to download files

bug

#1

OS: macOS Mojave v. 10.14 Beta (18A347e)

Brave Version:

Brave: 0.23.77
V8: 6.8.275.24
rev: 0125b5f5ddc7eebc832ceeb4f4275230ec49d149
Muon: 8.0.6
OS Release: 18.0.0
Update Channel: Release
OS Architecture: x64
OS Platform: macOS
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 68.0.3440.84

Issue:

(First things first… I know that I’m running beta software; I’m reporting this for informational purposes. Granted, a fix would be grand… but I’m not expecting one! I can download with an alternate browser if necessary.)

Brave runs find on Mojave this far with one issue. When I attempt to download a file (thus far any file; I’d tried a few) Brave force closes about 5 seconds into the download. I’ve attached a portion of the mac generated error log, but (I think) the error associated with the crash is:

Crashing on exception: -[_NSImageViewSimpleImageView setDoubleValue:]: unrecognized selector sent to instance 0x6000007ba120

Because I thought it might be useful for troubleshooting, I also tried a download with Chrome. It did not crash, but my Chrome version is a bit out of date (as I rarely use it.) After the update downloads and installs, I’ll test it again for crashiness, if that’s even a thing.

![errorlog-


#2

Update: Using Chrome 68.0.3440.84, there appear to be no issues, suggesting it may be unique to Brave.


#3

Thanks for writing this great report @chadpjd :slight_smile:

We received some reports about this and logged here

I added your +1 to the issue and you can follow the progress there.
Thank you,
:slight_smile:


#4

Thanks! I wasn’t aware of the GitHub community when I posted, else I’d have done so myself. My apologies for the duplicate report, then!

Tempted to leave Mojave installed in case Brave needs testers.


#5

Hi @chadpjd

While I wouldn’t turn you down on that, we do know that Mojave and Brave aren’t playing nicely at the moment, which could cause difficulties in day to day life. Please use whatever OS is best for you. If we need help and it works out that you still have it installed then that’s awesome. If not, that’s ok too :slight_smile:

Best,
Lauren


#6

Well, given that I locked myself out of recovery mode, the fact that my toolkit with the correct bits is a bit over 1000 miles away… I’ll be working with Mojave for a bit. Feel free to let me know if you need a quick test or seven. :wink:


#7

Ah, sorry to hear about the lock out but thanks for letting us know you’re available if needed :smiley:

Best,
Lauren


#8

I downloaded the recent Public Beta of MacOS Mojave from Apple on my 2014 iMac, and now Handbrake crashes every time it tries to rip a movie. Does anyone else have any experience with this?


https://bluestacks.vip/ https://textnow.vip/ https://photomath.vip/


#9

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.