Missing local wallet information

Briefly describe your issue:
Missing local wallet information
What Operating System and Brave version are you using ( Menu --> About Brave )?
Windows 10 Home 64 bit
Version 1.30.87 Chromium: 94.0.4606.71 (Official Build) (64-bit)

Is your browser wallet currently verified? (yes/no)
No

What date did you verify your wallet?
Last known good verification was in late September

Have you been able to successfully receive payments in the past?
Yes

Are you using a VPN? (yes/no)
No
Are you in a supported region (see here for list of supported regions)?
Yes

Does your device pass the SafteyNet check (Android only)?
Yes

Have you manually turned off Auto-contribute on all of your devices linked to Uphold??
They were never on.

Hello,

I am experiencing 3 problems which I believe can all be resolved with 1 solution.
For some reason, I no longer have any local Brave wallet information as displayed in the Brave://rewards-internals screen under the General Info tab:

Wallet info

Wallet was not yet created

Balance info

Total balance 14 BAT
bitFlyer Wallet: 0 BAT
Rewards BAT: 14 BAT
Gemini Wallet: 0 BAT
Uphold Wallet: 0 BAT

External wallet info

Wallet status: Not connected

As you can also see, BAT rewards were previously claimed as displayed by the Promotions tab:

686bfbfa-4675-4917-aceb-9598c21abbd8

Status: Finished
Amount: 8 BAT
Type: Ads
Expires at: 0
Legacy promotion: No
Version: 5
Claimed at: 08/07/2021, 02:27:50 PM
Claim ID: c1e840bc-4482-4d7d-9362-c2736fdd12ca

89060e91-4611-4f4b-8323-70d96c53376c

Status: Finished
Amount: 6 BAT
Type: Ads
Expires at: 0
Legacy promotion: No
Version: 5
Claimed at: 09/07/2021, 03:15:14 PM
Claim ID: 456bfd45-b41f-49ab-b342-7c8162412e57

The latest BAT rewards have also disappeared and were approx. 4 BAT and I’m pretty sure they have fallen into the bit bucket.

Additionally, when I select the Brave Rewards from the “Hamburger” menu, the “Ads” toggle is set to Off and I cannot set it to On by clicking on it. When I do try to click on this toggle, the 3 slider toggle appears for less than 1 second and then the Ads toggle goes back to the Off position.

Finally, I have set up a Gemini account without error but cannot link it with the Brave browser. When Clicking on the “Verify Wallet” button from the Brave Rewards page, once selecting the Gemini wallet and entering my login credentials, I always get the message that the operation cannot be completed and to try again later. This scenario happens regardless if I try to establish the link from the Brave Browser to Gemini site or the Gemini site to the Brave Browser.

I believe al of these problems stem from the fact that the local wallet information is missing from the Brave://rewards-internals General Info tab and once that info is restored, all of my problems will go away. My problem is that I don’t know how to fix this situation.

I’ve looked at all of the help info as well as community posts and while it does seem like this is not a unique problem, there does not seem to be a posted solution.

All other functions of the Brave Browser seem to work as designed and I do not get any error messages when doing anything nor have I experienced any unexpected crashes.

Any assistance provided will be appreciated.

Thanks,

-Bob