Middle Click scroll highlights everything - need option to disable!


#1

Hey I’m liking the Brave web browser but there are some things that are really quality of life bummers that I hope can be addressed in future builds. Whenever I scroll through a site via clicking down the middle mouse button everything I scroll over is highlighted. This is super annoying and I don’t have this issue in other browsers such as chrome. I understand others may like this feature, so if there is simply an option to “disable highlighting when middle mouse button scrolling” that would be great. I’d love to switch over to Brave as my default browser, please help make this happen!


#2

Hi @Whiplash,

I believe you face the same issue like described here Middle mouse drag selects text instead of just scrolling. Mind to checking and confirm?

Best,
:slight_smile:


#3

Yes that is the same issue I am having! Is there a solution for it?


#4

Sadly, no workaround for this AFAIK.
I added your +1 to the GitHub issue. And you can track the progress here

Best,
:slight_smile:


#5

I have found a workaround for this issue which has been working flawlessly. An added bonus is that auto-scroll functionality is added into Linux/macOS, a massive bonus for me at least! The fix involves installing this chrome extension named AutoScroll by kaescripts.blogspot using this tutorial. You can then configure the AutoScroll extension by going to the following address: chrome-extension://“extension_root_directory”/data/options.html. Replace “extension_root_directory” with the long, 32 character directory name. For example: bmnlcjabgnpnenekpadlanbbkooimhnj (I replaced Honey). I found that just changing the scroll speed to 2 is very comfortable for me.

As a side note, installing this extension in any chromium based browser adds autoscrolling functionality to Linux/macOS. Also, to avoid rooting around in Chrome’s directories, you may just download the AutoScroll extension using an extension like Get CRX by Adam Carbonell.