Metamask wallet extension not working

opensea.io tells me I need an Ethereum wallet for their site. I think I had metamask before, and removed it. I don’t see it in brave://extensions/.

So, trying to add, or re-add it again from https://chrome.google.com/webstore/detail/metamask/nkbihfbeogaeaoehlefnkodbefgpgknn.

After I click “Add to Brave”, I see:

“An error has occurred. This item is already being downloaded and added into Chrome.”

with Reload or Close as options.

Neither seem to differ. I checked brave://extensions/ again, it’s still not there.

It’s on https://opensea.io/wallet/install?referrer=%2Fcollections.

Is there a better wallet?
Why isn’t metamask working and what is needed to get it to work?