MetaMask Wallet Extension + Brave Contract Notification and Signing not working correctly

Description of the issue:
I use Brave as well the MetaMask Wallet Extension. So far everything always worked, login in to different decentralized solutions, without the need for a custody solution. Since 2 Weeks, I ran into difficulties using MetaMask and Brave.

Everytime, I try to sign/login, to a DEFI-Solution, I can’t sign the contract using Brave. The information for signing the according MetaMask Wallet and the DEFI Service is not getting displayed anymore.
Trying to change settings within the “Shields UP” configuration popup is not fixing anything.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Download / Enable Extension MetaMask
Connect to a DEFI-Service, e.g. IDEX / Ether Kingdoms / https://loomx.io/ (Loom Staking Dashboard).

Actual Result (gifs and screenshots are welcome!):




Expected result:
Contract Signing possible, connection to the decentralized service via smart contract signing.

Reproduces how often:
10 - 20 times

Operating System and Brave Version(See the About Brave page in the main menu):
Version 0.69.135 Chromium: 77.0.3865.120 (Official Build) (64-bit)

Additional Information:
Running Windows 10 (Surface Book)

@Alex1980,
I believe that this issue is known and currently being addressed by the team:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.