Metamask not connecting to Web3 since Crypto wallet option in Brave Dev preference

Since the new crypto wallet option in the Brave Dev version, I cannot connect to Web3 anymore with Metamask, or the Web3 won’t load or gets stuck.

Steps to Reproduce (add as many as necessary):

  1. go to https://dashboard.dappchains.com/login
  2. login with Metamask
  3. Stuck at “connecting to wallet”

Brave Version: Version 0.70.71 Chromium: 76.0.3809.100 (Official Build) dev (64-bit)

Reproducible on current live release: yes

2 Likes

This needs a fix A S A P !
Anything connected through metamask will not connect, and constantly redirects to the brave crypto wallet page.

Where is the toggle on/off? Why are you forcing us to set up a local wallet [more metadata]??

This is a terrible development for brave if it sticks around. Please fix ASAP !

2 Likes

Will there be a fix? Nobody else on the Brave Dev is using Metamask?

@mattches please take a look, wanted to but I haven’t started my test with local wallets yet

1 Like

Has this been solved? Metamask used to work but I tried to install Brave Wallet because this one app kept popping up the do a brave wallet. And now I cannot use Metamask again