Metamask does not automatically open window to approve/decline transactions


In Brave 0.19.122 for OS X with Metamask 3.13.0 I noticed the extension behaves differently than in Chrome. I’m not suggesting it’s a bug, but wanted to point it out.

What I expected to happen: Consistent with Metamask for Chrome, when I initiate a transaction on MyEtherWallet after having unlocked Metamask, I expect a pop-up window which allows me to approve or decline the transaction.

What actually happened: In Brave the result of initiating a transaction in MEW is different. After I initiate a transaction the Metamask icon is updated to have a number (to indicate that there are transactions waiting for approval, I guess) but no Metamask window opens in the browser frame to prompt me to complete the transaction.

This number is small and easy to miss (especially on very large screen), giving the user (me) the impression nothing is happening. Having the Metamask window open might be a useful prompt for an inexperienced user to complete the transaction.

But thank you SO much for including Metamask in available extensions.



I’m having this same issue and believe there are a few bugs between how it “should” work (see Chrome) and how it doesn’t work properly in BRAVE, see my list here:

  1. Each time I try and open metamask in BRAVE I’m shown the welcome and privacy statement, option to create a new account and/or import my existing DEN.

  2. Altcoins added to metamask do not stay in your token list and need to be added each time you restart metamask. In Chrome they remain as one would expect you.

  3. There is no “log in” or way to regain access to your account without inputting the seed phrase.


One last thing…

  1. It doesn’t open in the same elegant manner as in Chrome as appears with vertical and horizontal scroll bars in BRAVE


- This is what metamask looks like in BRAVE


I experience the same thing. Definitely should be popping up, and it isn’t!


BUMP - Any word on this guys?

closed #7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.