Menu text colors no longer visible

Description of the issue:
The menu items are no longer visible. Prior to the lastest update, it was a black background with a white text, not it is a black background with a dark text that cannot be seen.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Click on a folder in the bookmarks toolbar or the three lines on the upper right (the burger) and the items in the menu cannot be seen.

Actual Result (gifs and screenshots are welcome!):


Expected result:
The text to be a light color, visible on a dark background.

Reproduces how often:
All of the time

Brave Version(See the About Brave page in the main menu):
Version 1.2.19 Chromium: 79.0.3945.56 (Official Build) beta (64-bit)

Reproducible on current live release (yes/no):
¿Live release? This just happened after the update to this version, prior versions were fine. By live, do you mean stable channel? or the current version in the respective channel?

Additional Information:

Hi @thwaller,

Thanks a bunch for reporting! What OS are you on? Have you tried disabling Hardware Acceleration?

Sure. I am using Ubuntu 18.04.3, MATE 1.22.2 with Kernel 5.3.0-24. For hardware acceleration, I had not, but I tried it now so I could respond appropriately to you. It made no difference.

EDIT: I am also using the latest Chrome beta (Version 79.0.3945.70 (Official Build) beta (64-bit)) and this issue does not exist.

EDIT2: I am using theme Ambient-MATE with its defaults, no customization. I should have mentioned that prior.

Thanks for the additional info. We just noticed that you using Dark theme. Can you toggle back to Light mode in settings and see if the issue is still there? And then toggle back to Dark theme.

Ambiant-MATE is not a dark theme. Ambiant-MATE-Dark is the dark version. If you refer to “Brave Colors”, light and dark, I have already tried switching between them with no change in results. That setting changes nothing as it relates to the menus.

CCing my colleague @Mattches who can help to take a look.

@thwaller,
Can you confirm whether or not you have any flags enabled?

“Load Media Router Component Extension” is set to enabled.

To make sure it is clear, this settings is unchanged from when it was working on the prior version. Regardless, checking chrome://flags/ shows that is the only one changed from default.

Since you specifically asked on flags, I used the reset all to default option, restarted the browser, and there was no change.

@thwaller,
Is it safe to assume you’ve tried a system reboot since you’ve started seeing this issue?

@Mattches - yes, the system has been rebooted since.

@thwaller,
Can you try opening a Private window and/or a Guest window and see if you get the same results when attempting to view the menu?

@Mattches - both new private and new private with TOR have the same issue.

1 Like

@thwaller,
Thank you for confirming. I’ll have to do some more digging on this. Would you mind downloading/installing the Brave stable build and see if it shows the same behavior? Note that this installation will not overwrite or interfere with your current Brave installation – they’ll run in parallel.

@Mattches - yes I can do this today. I am aware of how the different channels operate in parallel with each other so no issues there.

1 Like

Let me know what you find out.

@Mattches - I was able to quick sneak this in. On Version 1.0.1 Chromium: 78.0.3904.108 (Official Build) (64-bit), the issue does not exist. I was sure to change the brave colors from light to dark in the settings to match the beta version. In both light and dark, there were no issues.

EDIT: I also see that Brave is wanting to see libva/vaapi at version 1.3 or greater. Ubuntu 18.04 LTS does not provide that, it provides version 1.1.

EDIT2: This issue is not only the Brave menu, but the bookmarks on the bookmarks bar in folders are not visible as well as the right click on pages. In addition to Google Chrome beta, I have also tested on Opera beta since it is also a Chromium based product. Neither have the issue.

Currently I am using:

  • Brave Version 1.2.19 Chromium: 79.0.3945.56 (Official Build) beta (64-bit)
  • Chrome Version 79.0.3945.74 (Official Build) beta (64-bit)
1 Like

I had same problem. I changed in Settings - Appearance - Themes to GTK+ It solved my problem.

1 Like

yeah having same issue on ubuntu 16.04.6.

difference is my default theme is set to GTK+ & when i switch to Classic the menu text displays fine (brave colors option set to Light for both ways).

id rather not use the Classic cause its too white for my liking. suppose i can just deal with hovering over menus to see selections for the time being unless anyone has any other ideas?

1 Like

It is strange that @suzie6 changes to GTK+ for the fix and @arenzy changes to Classic for the fix. For me, I tried and found that switching from GTK+ to Classic removed the problem, but switching away from GTK+ is not really a fix but a broken feature.

At least there are now 3 people who can confirm there is an issue here.

Same issue here. Running Ubuntu Mate. Software updater had some updates. After the update the issue arose. Not usable anymore. Looks like beta version has probs - where do I find stable release?

Thanks,
John