Megathread: For users seeing high CPU spikes/usage

For me, the real problem is the CPU time that’s taken up - by Gmail specifically. Messages is bad too but I had no idea until I left Gmail open overnight and checked task manager this morning.

Shield settings:

Actually looking at it now, blocking all Device Recognition could have something to do with it, I forgot I set that… maybe the service worker keeps trying to do so and getting caught in a loop?
Also, I had to allow all cookies or else gmail would give me a persistent authentication error across the top of the screen.

I do have a decently large amount of emails though if that helps (34,618 to be exact) - but I think they’re all still less than like 1GB altogether, plus that’d be more of a RAM issue I think? And gmail doesn’t take too much of any types of storage, just the CPU issue.

Windows 10 Insider build 19041
brave://version:

Brave 1.5.113 Chromium: 80.0.3987.149 (Official Build) (64-bit)
Revision 5f4eb224680e5d7dca88504586e9fd951840cac6-refs/branch-heads/3987_137@{#16}
OS Windows 10 OS Version 2004 (Build 19041.153)
JavaScript V8 8.0.426.27
Flash (Disabled)
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.149 Safari/537.36
Command Line “C:\Users\jdall\AppData\Local\BraveSoftware\Brave-Browser\Application\brave.exe” --enable-dom-distiller --disable-domain-reliability --no-pings --extension-content-verification=enforce_strict --extensions-install-verification=enforce --sync-url=https://no-thanks.invalid --enable-features=PasswordImport,SimplifyHttpsIndicator,WebUIDarkMode --disable-features=AutofillServerCommunication,AllowPopupsDuringPageUnload,LookalikeUrlNavigationSuggestionsUI,WebXR,NotificationTriggers,AudioServiceOutOfProcess,SmsReceiver,VideoPlaybackQuality,WebXrGamepadModule --flag-switches-begin --enable-devtools-experiments --enable-features=PasswordImport,SimplifyHttpsIndicator,WebUIDarkMode,NativeNotifications,OmniboxOnFocusSuggestions,OmniboxTabSwitchSuggestions,ProminentDarkModeActiveTabTitle,SharingQRCodeGenerator,StoragePressureUI,TabHoverCardImages --flag-switches-end --enable-audio-service-sandbox --disable-webrtc-apm-in-audio-service --disable-sync
Executable Path C:\Users\jdall\AppData\Local\BraveSoftware\Brave-Browser\Application\brave.exe
Profile Path C:\Users\jdall\AppData\Local\BraveSoftware\Brave-Browser\User Data\Default
Variations 5e3a236d-4113a79e
9e5c75f1-70ea8f25

CPU Pegs basically immediately on launch, will do it even with no tabs open, has for about two-three months. I’ve been using Brave a year or so and know it wasn’t doing this most of that time.

macoS 10.15.2 MacBook Pro (13-inch, 2016, Four Thunderbolt 3 Ports)
Latest Brave Stable update: Version 1.5.115 Chromium: 80.0.3987.149 (Official Build) (64-bit)

The Task Manager tool (didn’t know about that ) seems to make clear it is something about the BAT Ledger service?

If there is anything I can do to reset that somehow or troubleshoot it specifically to help improve things going forward, please let me know. A new profile seemed to have the same issue when I tried it as I noted on other threads.

editing this to add that this seems to correspond to another bunch of reports you can see here, most on macos, though not all, most with no meaningful response, many closed with no response. All noting the same behavior I’m seeing, almost totally pegged CPU. https://community.brave.com/search?q=bat%20ledger%20service%20cpu

For any users still encountering this issue:
We apologize for the inconvenience and hope it helps to know that we believe we’ve found the issue – we should have a new version with the fix out as soon as we can.

In the interim, if you go to: brave://flags/#brave-adblock-cosmetic-filtering , enable this flag and relaunch, you should see CPU usage improve. Please let us know if this is not the case.

Thank you.

Did that but it seems what you refer to may be different from my BAT Ledger problem (not surprising there is more than one issue, theirs seems more sporadic) Any suggestions for what ails mine @Mattches?

Here is a screenshot with the flag you noted enabled. Other details as noted in my previous comment.

Bat Ledger Service uses 100% CPU, that is until I end process and then it starts working again after 30 seconds.

image

image

1 Like

@psm1,
There’s a chance that you are experiencing something different entirely –

Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

@Mattches I’d certainly agree it is likely something different than the cause of the more spikey but not consistently high CPU usage. But it seems a widespread issue nonetheless based on the link I shared to many other threads describing similar experience, most without significant response. And from the additional person here reporting exactly the same thing shortly after I did.

I’ve had hardware acceleration off from advice in a previous thread or two attempting to get this figured out. On or off it doesn’t seem to impact the ledger service. I don’t think anyone ever responded with what the next troubleshooting would be after reporting that back. That has tended to be where the suggestions for additional troubleshooting steps stop.

Let me know what else I can do to help y’all get to the bottom of it.

@psm1,
Do you have any extensions installed in the browser at this time? If you were to create a separate profile on your machine, would you also see the BAT Ledger Service spike in the same way?

I only have two extensions installed at all but both are disabled to see if that helped with this. Also both had been installed long before this problem appeared although perhaps some updates to them could have triggered it, that seems unlikely to me though clearly not impossible.

In a separate Brave browser profile the CPU pegging does not occur also that profile has no Rewards turned on and none of the BAT I’ve accumulated browsing which seem like they could be factors. Is there some way to reset/“reboot” the BAT service that might get it out of its funk in this profile, without losing current data?

1 Like

Is Windows Defender your antivirus by any chance?

If that was directed at me, no. I’m on macOS Catalina 10.15.2. This is a company machine, it is running Forticlient Endpoint Security nothing around that changed that I’m aware of between the time this was not occurring and when this became a consistent issue.

Aha I think that cosmetic filtering flag did fix it

1 Like

Mac OS X 10.13.6

Brave is up to date

[Version 1.5.115 Chromium: 80.0.3987.149 (Official Build) (64-bit)]

Crazy CPU, up to 350% before update on one very simple website whilst a YouTube page was open.

YouTube pages would stop responding, mouseovers would register, i.e. cursor changes but controls totally unresponsive for long periods but sometimes control returns.

After update nothing has improved and in fact whilst trying to capture a screen, I had a pop-up saying that the page was not responding but it disappeared just as I was trying to capture it and the video played but the CPU for all pages was 0% except that one which was slightly >100%.

I also had a problem in the last few days that most YouTube videos suddenly would not play at all (I got a black playback screen with an error). I tested disabling all YouTube/video related extensions, all of which have been installed and running for months without issue and found that it was caused by AutoplayStopper which I disabled. I’m not saying that this is necessarily related but the problems began at roughly the same time and maybe there could be something common.

Dear Support,

I have tried the tips that Brave Support has offered such as use hardware acceleration when available. This did not fix the overload on CPU, so I deleted Brave. At the time I deleted Brave I was using macOS Catalina version 10.15.3. on the date 3/24/20

Then I installed macOS Catalina 10.15.4 on the date of 3/24/20 then re-installed Brave and opened the website that was causing me issue – https://login.exeterlms.com/ (Woz-U)

Finally, I opened Task Manager and noticed the problem did NOT stop.

@Derek,
Did you try changing the flag suggested in a previous reply above?

@Mattches

I tried the suggestion as mentioned and noticed no difference, so 100%+ CPU usage.

For the issue I, and some others have with the BAT Ledger pegging CPU constantly any more thoughts or ideas to troubleshoot?

A new profile does not have the issue but it would seem to defeat the purpose to lose all the BAT earned to fix the problem. Is there some way to reset the Ledger service somehow while maintaining the BAT? Or even to better profile/isolate what is wrong. I wouldn’t mind losing the BAT even IF it was in service of a permanent solution. I don’t like doing it if the problem could reappear for me and others.

1 Like

@Mattches any chance of further investigation, progress, suggestions on the BAT Ledger Service CPU pegging issue as I’ve asked above. Disabling or enabling hardware acceleration did not affect. Extensions don’t seem involved. The custom cosmetic filtering flag noted above did not help.

A new profile does not have the issue, so something in the profile is at issue. But losing BAT among other things whenever this crops up seems like a punt of a workaround. I’m happy to do more digging with some guidance to narrow things down more if I can. Anyone involved with the BAT Ledger Service I could work with?

I’m getting the following spikes.

Also, it’s preventing me from dragging the window away from one monitor to another.

I’m also seeing the Brave processes running when the program isn’t open.

@pinc,
In this context, when we say task manager, we’re referring to your browser task manager, as opposed to your OS’s task manager. You can view this by going to Menu --> More tools --> Task manager