May 31st Brave Update is Severely Broken

The browser display is incomplete. Calling up YouTube leaves all of the item boxes on screen BLANK. When pointed to the contents display, then turn off when not pointed at.

This is a real mess! BRAVE is BROKEN!

Description of the issue:

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):

Additional Information:

@sfarber5300 can you tell me more about your Linux setup? Just to confirm, it began when updating to 1.51.117? Thank you.

I am running Ubuntu 22.04.2, Mate 1.26 on a 4 Core 5095 Celeron with 8 GB Ram.

Brave doesn’t behave as expected. Firefox runs correctly on the same machine after closing Brave.

I have enjoyed Brave until now. This is just off the hook messed-up!

Please let me know when it is fixed.

@sfarber5300 Might want to check some of the below:

Guessing your issue is similar?

Yup! Except I had a 10 hour internet outage yesterday, so I was made aware of the issues with Brave when things came back up.

Brave doesn’t look like it should, in fact, it is UNUSABLE in its present form. The second screenshot above is similar to the issue I found.

I am very disappointed by this blown update and am rethinking my use of Brave.

@sfarber5300 big thing is can you try what they mentioned? GPUCache?

Also have to ask, where do you get your Brave updates from?

I have no idea how to deal with a GPUCache. My machine has an Intel graphics chip to accompany the Celeron. Both work fine on everything else.

I’m not sure if it might help guide you a bit, but link below.

But I know @steeven is also looking into it and trying to help. If he has any other solutions or can provide better instructions for you, hopefully will do it. I just wanted to drop in to offer these links as it sounds like your issue is the same. So it’s just a random suggestion/thought.

That’s nice of you, but this update is a little borked. I’m disappointed that after so many smooth updates since v1.0, we’ve taken a step back. (I can say this because I never fell for the BAT/Rewards scam…)

1 Like

I neglected to answer earlier about the source of my updates: they come from Ubuntu’s software update as far as I can tell. This has never been a problem. I’m running Ubuntu 22.04.2.


Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

I cannot see the settings to read or alter them. Brave has been profoundly FUBAR’d.

Yes, it is THAT BAD!

Oh so you are seeing this occur even on internal pages? Interesting.

If that’s the case it’s unlikely that HWA is the issue but I think it’s still worth a shot — can you please try launching Brave from the Terminal, using the --disable-gpu flag? Command should look like:

brave-browser --disable-gpu

I just tried it and it failed to produce any change. YouTube offerings still are blank, but appear briefly when pointed to.

Sorry @Mattches, no joy!

I just received Brave
Version 1.52.117 Chromium: 114.0.5735.90 (Official Build) (64-bit)
( as part of an Ubuntu update. It seems to work so, I guess we’re done here. I’d really like to know how the pooch got screwed on this one. It makes a terrible impression on the users when this kind of think happens. Better safeguards against shipping bad code seem to be needed. Cheers!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.