March Rewards got vanished second time. What is happening?

I just received 1.25 BAT as the march rewards which was supposed to cover up the last time when I received only 0.25 BAT and it got vanished.

But again? I followed their claim button, it got added, stayed there for couple seconds and then again got vanished. Not sure really what exactly is happening here.

Losing my interest and hope in this.


If you’re having difficulty with the new claim, the browser will automatically update and retry in a bit.


me too bro . I have two laptops .i can’t claim and there was an error.

Im having the same error

I think brave is a big tech company. There was errors month by month . It is unacceptable

Thanks @steeven, will keep an eye on it to refresh.

Hello mate, It happened too, but for the second time (in this second march rewards time) also they got vanished in the haze. I mean after retry in a bit.

“big tech company” might be slightly over-exaggerated. They have like 30 people working for them.

same thing happened to me today. i opened my brave browser and when i looked at my rewards it said that i earned a 4.0 reward for march but when i tried to do the captcha thing to claim my reward it just vanished and never got credited to my account

I have the same problem. I received .25 BAT on April 7 and then received the remainder today. When I tried to claim it, it vanished. How do I get it back?

Facing the same issue :smiling_face_with_tear:

I did get it few minutes ago. i got the claim button now its on gemini. Thx brave

1 Like


I too received the claim message for the second time this cycle, and for the second time NOTHING was credited to my verified wallet. Same balance I have had since last payout. It would be nice if someone could explain how something that should have been heavily tested could perform so poorly once in production. This is not a new issue and every month I have been using Brave it is always some kind of delay or problem. I know you folks are working hard and doing your best, but my friend this system is just not ready and needs some serious refactoring.

1 Like

I also did not get the ones that I collected in my account and I am thinking of uninstalling the searched one not for that, but for not complying

Yeah , bro it is not local company , it’s global and have millions or user

Same here. Not sure where did my March rewards went to after pressing the claim button. It was not added to my account balance. Hope this get sorted out

Update: Try updating your browsers. Saw an update on my browser, launched the update then closed the browser after the update completed. Opened a new instance, I can now see my March rewards credited to my account.

1 Like

wait brother i got my reward of 7.25 bat


By when will the people who haven’t received their last mon the rewards be paid in their Gemini and uphold accounts?

It’s been 10h and it hasn’t retried yet :frowning: After the captcha failed for me, my BAT claims just up and disappeared

Hey, I got the claim button again as well, and when I used it, it showed all of my BAT as deposited. It did not show up in my Gemini Account, until about an hour later, but it did work for me! First time in 3 months I got my rewards! Kudos to the Support Team, great work!

1 Like