Manually typing URL which gives 301 response only does Google search


#1

Android v4.2.2; SGH-I337M Build/JDQ39
Brave v1.0.33

This does not happen in Firefox or Chrome.

Note: I first tried posting this but was not able to as this site told me as a new user I can only post two links. Given that this problem is directly related to browsing to manually-typed URLs I don’t know how I could explain the problem without including the links, so I hope filtering out the dot before the TLD isn’t a severe violation of the rules here. (I also had to exclude the protocol for it to post, but all four of them use HTTPS.)

Whenever I manually type a URL into Brave, other than just the domain name, it will do a Google search rather than loading the page if the server responds with an HTTP 301 code. For example if I type in newgrounds[dot]com it will browse to Newgrounds as expected. But if I type in newgrounds[dot]com/games it does a Google search for that text even though that is a valid URL (that gives an HTTP 301 response.)

I did some playing around and found out that typing newgrounds[dot]com/games/ and avoiding the 301 with the forward slash at the end will load the page correctly. And similarily, if I type community[dot]brave.com/c/help-me/android-help-me into the address bar it will load with the 200 response, but if I add the forward slash onto the end Brave’s community URL (i.e. community[dot]brave.com/c/help-me/android-help-me/) and get the 301 it again does a Google search.

Brave also appears to be doing this whenever a site responds with an HTTP 404 response, which is making it difficult for me to test 404 handling on websites I am working on when using my phone.

I am unsure if this happens for any HTTP response code other than 200 as I’ve only been able to readily test with 301 and 404 responses.

Is this a bug or is it by design? If it is by design, can I disable this behaviour?

Thanks.


#2

I cant reproduce this issue. Could you try clearing cache once and check if it loads.


#3

Strange. This was happening for every 301 response on Wednesday on any site, but I cleared my cache (and everything else) as you suggested and now the problem has completely gone away. It started after a first/fresh install so I don’t know what caused that to happen.

Anyway, it has stopped happening and that’s good. Thanks.


#4