Manually adding cookie control exceptions


#1

Is there a way to add cookie control exceptions without going to the site? I use a site that tells me explicitly which domains need to have third party cookies enabled but some of those domains I cannot directly go to. I don’t want to enable all cookies on all sites.


#2

Hi @UnclePa,
If I’m understanding your question correctly, you want to know how to add exceptions to certain domains to “allow” cookies - but without actually visiting the website? Can you explain what you mean by “some of those domains I cannot directly go to” in a little more depth? What exactly is preventing you from going to these sites?

Additionally, forgive me if you are already aware of this, but you can toggle site-specific Shields settings by using the drop-down panel (Lion icon in the top right) when visiting the site in question. The settings shown in the panel will only effect the website currently in focus. If there is something preventing you from getting to that point, then reply back and we can look for additional workarounds. However, if you wanted to enable cookies for, lets say brave.com for example:

  1. Navigate to Brave.com
  2. Click the lion icon
  3. In the drop-down panel, under cookie control, select (“allow all cookies”)

The webpage should automatically reload with this new configuration and it will be saved for that domain until you specify otherwise.

I hope this helps!


#3

Thanks for the reply. I know about using the shield drop down for the current website. In one particular case, Atlassian says it needs 3rd party cookies for 4 different domains, one of which is jira.com. But if I try to go to jira.com, I get redirected and I don’t see a way to make it the current website. So, is there a way for me to manually add jira.com to the cookie control exceptions?


#4

When you’re redirected, do you get redirected to the Atlassian website (https://www.atlassian.com/software/jira)?


#5

Yes. And cookies are already turned on there. “atlassian.net” is another one that redirects to atlassian.com. So, for all the sites I can make current, cookies are turned on. But it still complains that 3rd party cookies need to be turned on and lists 4 domains that need them, only two of which I can get into the exception list. In searching for an answer, it looked like the solution was to turn on all cookies for all sites. I wanted to avoid that if possible.


#6

I ask because using both FF and Chrome also redirect me to Atlassian.com.
Furthermore, I’m able to navigate to our Statuspage account in Brave while blocking cookies, as well as login to id.atlassian.com with Shields up, blocking 3rd party cookies.

This makes me think there’s something else at play here.
Are you able to navigate/login to id.atlassian.com? Also, are you logging in manually or using Google auth to login?


#7

FWIW, I was able to log in and browse our issues with tor-browser, iron64, and FF on this same machine. I’m logging in manually and, yes, I can go to id.atlassian.com and see my info. I cleared the cookie exceptions and it will let me log in, but after logging in, I still get:

Atlassian
xxxxxxxx.atlassian.net
Something has gone wrong
Check that your browser allows third-party cookies and then try again using the button below (without refreshing the page):

Try again
For more information see Troubleshooting Atlassian Account.

Try a different account

Terms of use  Support  Privacy policy

Edit: Thanks again for the replies. I take it the answer to my original question is “no.”? I can sort of get 3 of the 4 sites that Atlassian says needs cookies. I’m not sure that enabling cookies on “mycompany.atlassian.net” has the same effect as enabling it on just “atlassian.net”. But I see no way to enable them on “jira.com” without enabling them everywhere.


#8

So yes, the answer to your original question about whitelisting cookies manually is “no”. I’m not sure if anyone has pointed you here yet but we’ve had this requested before but its unlikely it will be implemented before we switch over to our Chromium-fork.

However, I’m going to hold off on closing this issue for just a bit. I find it odd that I’m able to access the sites/domains in question without issue, regardless of my cookies settings.

I’m going to dig around a little more and I appreciate your patience as we work through the issue. While I look and ask around, would you mind posting your about:brave information for me?


#9

Thanks again. I’m using Devuan Linux. Below is about:brave. Installed it about 3 days ago and don’t think I’ve changed anything from the default configuration (other than the cookie thing).
Brave: 0.23.39
V8: 6.7.288.46
rev: 3ee14b026f09d7d71c1985b4a9c9a11d78ab8f49
Muon: 7.1.6
OS Release: 4.9.0-7-amd64
Update Channel: Release
OS Architecture: x64
OS Platform: Linux
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 67.0.3396.103


#10

@mattches Because of all that (above) I thought it might be that this issue only arises if you / your company use(s) Jira for ticket management and after logging in… But by chance I have an account into some ticket management using Jira, so I just tried and I can log in into it without a problem - with Shields up and 3rd party cookies blocked. Alas, I have only read access, so I can’t do much.

@UnclePa Does the problem appear by itself immediately after logging in or do you do something specific (e.g. (trying to) edit a ticket) before it appears?

But that aside, I hereby express my +1 for the ability to manually white-list a domain to allow cookies. :smiley:

Edit: I just had an idea:
@UnclePa When you go to “mycompany.atlassian.net”, change the site settings to allow 3rd party cookies. The ticket system can be expected to be safe, isn’t it? And everywhere else, 3rd party cookies should still be blocked. (Edit 2: Unless you already tried… but I think “jira.com” should be a 3rd party when visiting “mycompany.atlassian.net”, so I see a chance that this might work.)

Edit 3: Sorry. Mattches already suggested this in his 1st answer and you said you already tried this before.


#11

What I posted was the first thing that comes up after logging in. There is some delay so it isn’t immediate time-wise, but it is immediate sequence-wise. My Cookie Control list from the Preferences screen is:
atlassian.io: Allow all cookies
mycompany.atlassian.net: Allow all cookies
www.atlassian.com: Allow all cookies

Of course “mycompany” is not literal. It is actually a client’s site, but I do have access using other browsers as mentioned before. Moreover, I just tested this–I installed Brave on my laptop which is also running Devuan and got the same results. I enabled all cookies for all sites and it works correctly, so I’m quite confident the problem is with cookie permissions. As mentioned before, I really do not want to enable all cookies on my main computer.

Edit: FWIW, playing with it some more on the laptop with all cookies enabled, while browsing issues, if I turn off all 3rd party cookies, I can’t log out–it takes me to the Dashboard still logged in. If I allow all cookies again and log out, it takes me to the log in screen as expected. Turn off cookies and log in, I get the “Something has gone wrong” screen again.


#12

Heh, all I really wanted was an answer to my question since I have a work-around. However, this might be useful to others. On the laptop with all cookies turned on, there is indeed a cookie with host_key of jira.com. There is not one on the desktop where I’m getting the “Something has gone wrong” screen. I strongly suspect that if I could somehow enable 3rd party cookies from jira.com it would work.

Edit: Trying out eljuno’s suggestion.


#13

@UnclePa I rather guess you put too many “links” (the “fake” ones for “mycompany” included) into all of your post altogether, while being a “young community member”, and the post were flagged by some robot that couldn’t tell spam from anything else, not “by the community”. For sure none of your posts (up to now :wink: ) are spam.

@eljuno Could you help with this or do you know someone who could help to get UnclePa’s posts un-flagged?


#14

Yeah, I got a message about it this morning that said I could edit it in 10 minutes but I had made the post last night and I couldn’t edit it this morning. Now it let me edit it, so perhaps it will show up eventually. The annoying thing is that “I” didn’t put any links in via markup, “It” did. :smile:


#15

@tlaloc77 un-flagged. :smiley:

@UnclePa, yep. The system flagged your post automatically because you repeatedly post same link multiple times. To avoid this, you can try to cover your link with backtic ` at the beginning and the end of your link.


#16

Thank you for helping - and Special thanks for the info about the backticks!


#17
  1. Navigate to Brave
  2. Click the lion icon.
  3. In the drop-down panel, under cookie control , select (“allow all cookies ”)
    isnt this the simplest way?

Mini Militia App Lock 7Zip


#18

If you want to enable all cookies for all sites, yes, it is simple. But that wasn’t the question.