Mailto (xdg-open) still not working on Linux

Multiple tickets, by multiple people, have been filed against mailto and other xdg-open requests not working properly in Linux. There seems to be no resolution, and no recognition by the developers that this is a valid problem. So here are several unresolved tickets, in one location, in hopes that some developer will take this seriously:

There are additional reports–this is a partial list. You will find others here, if you search for xdg-open.

This is very easy to investigate: Boot any Live Linux via USB, install Brave, and install some email client—such as Thunderbird. Select that email client as your preferred default email program. Click on any mailto link, and allow xdg-open to handle the request. You’ll see that nothing happens, no email window ever opens. This is not only a Brave issue: mailto works in Firefox, Midori & Falcon; but fails in Chromium, Brave, and Opera.

Even if it did work, the “remember” function is flawed, it asks for permission to remember on a website-by-website basis, rather than a protocol bases: So if you tic the box to remember mailto links on one website, it will ask you again on each new website—rather than just remembering that all mailto links should be referred to Thunderbird.

This applies to several versions–as you can tell from the age of some of these tickets. I happen to be using Version 1.18.78 Chromium: 87.0.4280.141 (Official Build) unknown (64-bit) on a Manjaro (Arch) Linux (Stable) KDE desktop

Please, developers, fix this old issue.

Can you please tell me what appears when you enter the following command in your Terminal?

$ xdg-mime query default 'x-scheme-handler/mailto' 

Additionally, if you hit Alt + Space and search for Default Applications you should see the following menu – ensure you have Thunderbird (or your desired email client) configured here as well:

$ xdg-mime query default ‘x-scheme-handler/mailto’

…and yes, Thunderbird is the only email client on this computer, and it is set as the default email app through the KDE system settings.

Here’s one more thing to try:

/usr/lib/brave/xdg-mime query x-scheme-handler/mailto
/usr/lib/brave/brave/xdg-mime query x-scheme-handler/mailto
/usr/lib/brave-bin/brave/xdg-mime query x-scheme-handler/mailto

(not sure exactly which is the right path on Manjaro)

Also, if you could take a screenshot of brave://settings/handlers, it might be useful in helpful us figure out what’s wrong on your machine.

We’ve been unable to reproduce that problem using the official packages on Ubuntu 20.04, Debian unstable and CentOS 8. It’s possible that this issue is specific to the integration with Manjaro and/or the unofficial packages that they ship.

Hi. Are you using KDE Plasma with Xorg or with Wayland? I use Arch Linux + KDE, so pretty similar setup to you. When I ran KDE with Wayland opening mail didn’t work for me either, but it works fine on Xorg.

Handlers are enabled, and the only entry in settings/handler is web calendar > There is nothing else there.

I have no idea what you want me to do with /usr/lib/brave/xdg-mime query x-scheme-handler/mailto
If I enter is on a command prompt I get:
bash: query: command not found
If it’s something else, I’ll need more instructions.

I had to check, it’s X.

Try running the other two to see if one of them works:

/usr/lib/brave-bin/brave/xdg-mime query x-scheme-handler/mailto
/usr/lib/brave/brave/xdg-mime query x-scheme-handler/mailto

having the same problem. my output for the above in debian sid on kde using x is
$ xdg-mime query default ‘x-scheme-handler/mailto’


$ cat .local/share/applications/thunderbird-3.desktop

[Desktop Entry]
Exec=/usr/bin/thunderbird %u

$ /opt/ query x-scheme-handler/mailto

xdg-mime: unknown query type ‘x-scheme-handler/mailto’
Try ‘xdg-mime --help’ for more information.

i am able to run in a command line xdg-open and a thunderbird new mail message dialog box opens

I’m sorry, there was a typo in the command I asked you to run. Here’s the command without the typo:

 /opt/ query default x-scheme-handler/mailto

(there is a default between query and x-scheme-handler/mailto)

xdg-mime query default x-scheme-handler/mailto returns:


xdg-email returns:
/usr/bin/xdg-email: line 599: thunderbird.desktop: command not found

But that’s incorrect. thunderbird.desktop does exist in /usr/share/applications and here’s what it says:

[Desktop Entry]
GenericName=Mail/News Client
Comment=Mail/News Client
Exec=thunderbird %u

Footnote: Not that it matters, but I’m also working on an OpenSuse (stable 15.2) system with the exact same problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.