Magic Eden Not Loading

Description of the issue: hasn’t been loading at all for me in Brave browser for over 2 weeks now - cleared cache/cookies, disabled my VPN, still nothing. Loads fine in Chrome or anywhere else. This is unacceptable for a “web3” browser.

Exact URL of the website in question:

Did the issue present with default Shields settings? (yes/no)
Yes, the issue is still present even after adjusting the global shield settings.

Does the site function as expected when Shields are turned off?

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):

Does the site work as expected when using Chrome?

Brave version (check About Brave):

While I didn’t try connecting my wallet or anything, this site does seem to load for me without any issue using the latest version of the browser. Can you be more specific about what happens? Does attempting to load the site result in any errors or does it just infinitely load, never actually landing on the site?

Does this work for you when trying to visit the site in a Private browsing window?

The frame of the homepage comes up, but the content just infinitely loads and never actually populates (similar to an AMP webpage when its loading).

Also, it doesn’t work in a private browsing window either.

Website loads fine for me as well. I clicked on several links and on links in new pages - all work properly for me.

Would you mind trying to create a new test profile (ensure you close the original profile window you had open), visiting the website and tell me if Brave behaves the same way when using it?

Created a test profile and tried it, still not working.

Very strange behavior. Are you on Windows, Linux or macOS here?
If it’s working on Chrome for you but working in Brave for me (and other users reporting here) there must be something specific to your Brave setup causing it — but then the new profile should be displaying the site correctly.

Can you please visit the site (in Brave) and show us a screenshot of the dev tools console window?

  1. Open Dev tools (Menu --> More tools --> Dev tools --> [Console tab])
  2. Visit the site
  3. Take a screenshot of any output shown in the console tab of the dev tools window

I’m on Windows. Here’s what my console window shows:
console errors

Thanks for the info, will review with the team.

I’m curious about what (if any) filters you have enabled in brave://settings/shields/filters? That is, what boxes are checked and/or are there any entries in the Custom filters list ?

No filters enabled, no custom entries in my custom filters either.

1 Like

A couple more tests for you if you’re willing (as none of this makes any sense):

  • Can you try disabling secureDNS temporarily to test and see if the page loads?
  • If the above does not work, can you please try downloading our Beta Build and testing to see if you get the same results when using it (note that it will install in parallel with your current Brave installation and will not overwrite/delete any data)?

Still not working after disabling secureDNS, and the site still doesn’t load even after installing the beta build and trying to load from there.

This is super weird — I’ve pinged the team and am going to cc our one of our Shields/web compatibility team members @fanboynz to take a closer look at this.

If you load Brave on a different computer does it show the same issue?

Not sure what changed since my last reply, but magic eden suddenly started working again for me in brave browser now. So my problem seems to have been fixed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.