macOS: Brave Beta is crashing on launch

#21

Hmmm… still no luck. Here’s what I did.

  1. Downloaded Brave-Browser-Beta.dmg from https://github.com/brave/brave-browser/releases/tag/v0.63.35
  2. Once the download completed, I shut down Brave (release)
  3. Checked Activity Monitor, and didn’t see any processes listed there for Brave
  4. Opened the .dmg file I downloaded, and copied Brave Browser Beta.app (version 74.0.63.35) to my Applications folder.
  5. Tried launching Brave Browser Beta, but it crashed again.
  6. Went back to ~/Library/Application Support/BraveSoftware, but I still only have the one Brave-Browser folder.

Crash reports are at:

  • https://pastebin.com/7bycNyZb
  • https://pastebin.com/4zSAfxE4
0 Likes

#22

I wonder if it could be a permissions issue. @OctoSpork . I used to use DiskWarrior for that, but you could just run First Aid from Disk Utility.

0 Likes

#23

@hnktong - I’ll give that a try later tonight. (Just can’t lock up my drive right now while it runs the First Aid checks.)

0 Likes

#24

Could be. Still very strange that Release would install and run without issue but beta and dev are getting caught up on something.

I pinged some team members for additional input, will return when I have more information. Thank you again for your patience @OctoSpork

0 Likes

#25

Any success here, @OctoSpork? One other request (which may be a shot in the dark) is to validate all fonts in Font Book. Open the app, CMD+A to select all, then right-click and Validate All. I suspect this will yield no problems, but at this point it doesn’t hurt to be thorough :slight_smile:

0 Likes

#26

I would absolutely love it if this worked.

0 Likes

#27

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

0 Likes

#28

Tried confirming fonts both pre & post install. Here’s the crash report:
https://pastebin.com/ PdWRpz2e

Might have found the smoking gun in console logs. Looks like there’s a dir missing somewhere? Here’s a copy of the logs

https://pastebin.com/ m3MadHdi

0 Likes

#29

I also tried verifying fonts, and although a handful were flagged as duplicates, I didn’t see any difference in crashes, even after resolving the duplicate fonts.

1 Like

#30

I fixed it on my system! I was having the same problem, and hoping for an update in the thread. I had the same issue with a Brave-Browser but no Brave-Browser-Beta folder in ~/Application Support/BraveSoftware.

I also saw someone mention a console post about a missing dir.

I figured there was no reason not to try something, so I created an empty folder called Brave-Browser-Beta. I actually planned to transplant the contents of Brave-Browser into Brave-Browser-Beta, but figured I would try launching Brave Beta first.

To my surprise, it launched no problem! Not only that, the contents of the Brave-Browser-Beta folder appear to have been properly created at launch! It appears that, for whatever reason, the folder isn’t being properly created on launch, and once you create it everything works fine.

I have not extensively tested the browser, so all I can say for sure is that it launches and loads MacRumors. I have not (and am not planning to) test the Dev or Nightly builds.

Hope this helps others now, and ultimately helps the team fix the problem.

2 Likes

#31

@eeeepp -

That was it! I was able to verify that your suggestion worked on my machine as well. Using Brave Beta 74.0.63.40, launching the app, it would crash immediately. However, once I created the following directory: ~/Library/Application Support/BraveSoftware/Brave-Browser-Beta - Brave Beta would launch, and works great. I’m running it right now.

cc: @Mattches

1 Like

#32

So glad to hear this – can you confirm for me that that directory that was just created does get populated with profile data?

0 Likes

#33

Yes - once Brave Beta launches, the Brave-Browser-Beta directory is populated with data.

1 Like

#34

This is great news! Glad we got this figured out – and by “we” I mean “you” @eeeepp!
I’ll make sure the right people get this info so we can find out why this is happening but will close and mark the thread as solved for now. Please let me know if anyone has further questions surrounding the issue.

0 Likes

closed #35
0 Likes