macOS: Brave Beta is crashing on launch

#1

After downloading version 73.0.63.29 of Brave Beta, the app crashes immediately on launch for me. Any suggestions would be appreciated.

To reproduce:

  1. Download Brave Beta from https://brave.com/download-beta/
  2. Copy Brave Beta from the downloaded disk image to the Applications folder.
  3. Launch Brave Beta
  4. Watch it crash

Expected result:

Brave would launch and not crash.

Reproduces how often:
Every time.

Brave Version(See the About Brave page in the main menu):
Based on the info available in Finder, 73.0.63.29

Reproducible on current live release (yes/no):
No - the current live release works great.

Additional Information:
My system info is below, and a crash report is here. Every crash generates a similar report. (I tried to attach the crash report, but it looks like text files can’t be uploaded here.

System Info
Model Name: MacBook Pro
OS version: macOS Mojave - 10.14.3
Model Identifier: MacBookPro15,1
Processor Name: Intel Core i9
Processor Speed: 2.9 GHz
Number of Processors: 1
Total Number of Cores: 6
L2 Cache (per Core): 256 KB
L3 Cache: 12 MB
Memory: 32 GB
0 Likes

#2

@OctoSpork,
Thank you for reaching out.
I just downloaded and installed Beta without issue on my macOS (same specs). Would you mind downloading the Release or Developer build and see if they also crash on launch?

0 Likes

#3

@Mattches -

I get a similar crash in the developer build, but the Release build (Version 0.61.52 Chromium: 73.0.3683.86 (Official Build) (64-bit)) works great. Using it right now.

1 Like

#4

@OctoSpork,
Glad you got Release up and running. Going to look into Beta/Dev crashes and see if the team knows anything. Thank you again for reaching out. If you’d like to help, you can send your Crash reports to Brave by going to brave://crashes and clicking “send now” underneath the crash. These will be sent automatically unless the option to do so is disabled in settings.

0 Likes

#5

Same thing is happening to me here’s the crash details from the system: https://gist.github.com/Nick-Harvey/7614c8a83b6b6af0cc8a597485f49bb5

0 Likes

#6

I think brave having difficulties with IOS devices… so far no reward version for IPhone :calling: devices :eyes::robot:

0 Likes

#7

So far, Brave is working well on iOS for me - it’s the beta builds for macOS that are crashing.

0 Likes

#8

@Mattches -

I’m still seeing crashes on launch after upgrading to beta 74.0.63.35 (63.35).

Crash reports are posted at:

(I’d submit them via brave://crashes, but Brave Beta never completes launching, so that’s not an option.)

0 Likes

#9

@Mattches -

I’m still seeing crashes on launch after upgrading to beta 74.0.63.35 (63.35).

Crash reports are posted at:

https://pastebin.com/<CRASH_ID>

Since the forum software doesn’t like multiple links to the same site, and flagged my last post as spam, you’ll need to replace the <CRASH_ID> above with the following crash IDs below to view the crash reports.

Crash IDs:

  • SDkp9CaQ
  • nRtBJ4fU
  • TjAJF2XX

(I’d submit them via brave://crashes , but Brave Beta never completes launching, so that’s not an option.)

Brave Dev (74.0.64.40 (64.40)) is also crashing on launch:

Crash IDs:

  • vrPi37wz
  • Vv98UYKm
  • Af4qjk5u
1 Like

#10

@OctoSpork,
Sorry for the late reply – still looking into this. Appreciate the workaround effort with getting the crash reports to us. I will go ahead and push those to the team on your behalf.

May seem like a silly question but have you un/reinstalled yet? If so, when you did, did you remove any associated browsing data with Brave Beta?

0 Likes

#11

I have uninstalled the beta/dev builds a few times. Not sure that there would be any browsing data though, as only the release build will actually run on my machine. Where should I look for any other data to delete? I checked in ~/Library/Application Support but didn’t find anything that looks like it belongs to the beta/dev builds.

0 Likes

#12

You probably looked in the BraveSoftware directory, @OctoSpork, but in case you didn’t, do, because there are separate folders for release, Beta, and Dev, thus (click image to embiggen):

0 Likes

#13

@hnktong -

Thanks for reminding me to double-check the BraveSoftware directory. I did look in there just now though, and I only have the one Brave-Browser directory - nothing for beta or dev. Looks like those builds are crashing before they have a change to create their directories.

0 Likes

#14

@OctoSpork,
That’s very strange. Profile paths should be created and assigned before the browser ever launches. Are you downloading directly from the official download page?

0 Likes

#15

@Mattches -

Yeah - I’ve been getting the downloads from:

0 Likes

#16

I apologize for making you repeat yourself but I’d like to confirm you for sure have no folders there (again, not because I think you’re inept - just want to make sure everyone is on the same page!). To confirm, please try the following:

  1. Open your terminal
  2. Change directories to where Brave stores files (or where they should be). If you’re unsure or unfamiliar with terminal, type the following command: cd Library/"Application Support"/BraveSoftware/
  3. Your terminal should now show something like this:

Can you share a screenshot of your terminal after performing the steps above as I did?

0 Likes

#17

@Mattches -

It’s no problem. I’m a dev myself, so I get wanting to double/triple/etc-check things. Here you go:

44%20PM

0 Likes

#18

Appreciate your patience and willingness to work with me.
Do you currently (still) have Beta or Dev “installed” on your mac? If so, do they show up in the Applications folder?

0 Likes

#19

I do.

  • Beta: 74.0.63.35
  • Dev: 74.0.64.40

45%20PM

0 Likes

#20

:thinking::thinking:
Alright, last idea I have at this time – go ahead and uninstall those apps. Once trashed, try grabbing the .dmg from our github directly for beta:


Before unpack/installing Beta again, make sure all Brave processes are closed. After installation (whether the app launches and crashes or works), check the same Application Support/BraveSoftware directory again and confirm that you now have a Brave-Browser-Beta directory here.

Let me know what you find out.

0 Likes